Cataclysm: The Updated Great Underground Challenge! [WIP]

In summary, you could tell the whole thing was a terrible idea, you got separated from your group, wrecked the escape vehicle, and only barely managed to close the subway station gate before the horde arrived. At least you are safe now and securely trapped inside the subways of the city, but at least it beats being eaten by the zombies on the surface right?

Anyways, there’s not much to do inside this tunnels, so better get going, I bet the next way up is not far from here, a few hundred meters at most…

The Great underground challenge is an underground dungeon I have been slowly working on for a few weeks now. In it, you traverse the infested subways and sewer in search for the way up, sounds like an easy task, doesn’t it? Well. unluckily for you I did some modifications to the vanilla underground, and poor John will stumble into a wide array of things, from the mundane piranha infested sewers and zombie filled tunnels, to underground fungal forests and eons-old underground temples; so yeah it wont be easy.

Building whole dungeons with the debug menu is not an easy task, and progress is steady but slow. A lot with the of things are still missing, and on its current stage the whole dungeon is rather small, but already presents some nice challenges and settings.

I invite you to play it and give suggestion and critiques, really anything that you could say works; from the general: the whole thing needs more seweranhas, to the extremely specific, that central locker in the room with the dead NPC being eaten by a Jabberwok could use a wrapped radiation badge on it.

[spoiler]Some Gameplay and technicall stuff
With the starting skills, the dungeon is kinda difficult, and will possibly take you a lot of effort to go forward without dying a lot, so its assumed that you will allocate yourself some skill points using the debug menu at the start, no doing it should be considered the “hard” mode of the dungeon.

Occasionally, you may stumble upon illuminated rooms, the light is coming from paper wrappers somewhere in that room. Grabbing them will result on the lights dying and ruining the scene, and will net you an item that will illuminate rooms when dropped. This is of course considered cheating, but no one is watching anyways :stuck_out_tongue: (No seriously don’t grab them or Ill spawn jabberwocks on you.)

You have two rather strong bionics at the start of the game (cloaking system and probability travel) which were used during the creation of the dungeon, again, using them under every context is considered cheating, no mattering the hell you went through to get those batteries.

Lastly, exploring the above ground is not very interesting and is not part of the dungeon, but f you feel like being spoiled, the two blocks north of the subway station you start in have some interesting stuff in them but are completely empty otherwise, also watch it, there might be some amigara horrors roaming around just to discourage derailing [/spoiler] [/spoiler]

You can find the latest version here
-to play it just uzip the folder into

Version 0.1

(You will need the latest experimental (the tile version) before playing it though.)

This could be great as a mod!

Seconding this so much!

Theres no way for me to posibly make it a mod tough, as that would mean dumping and recreating a lot the map gen code from scratch, which is something much more difficult that what I can manafe, so sharing a save file with a dungeon I debug built, is unluckily the closest alternative possible.

But its nice to know that you guys like it, also the current version has a rather jarring bug, it seems that animals-skin walls are indestructible unless they are under pretty specific conditions, so some(all) of the bonus rooms are not accessible, Whoops!

It should be fixed for the next release .

I’ll give a try right now with the 0.9-3449-g5c72396.

I’ll write down thing I think that should change. I won’t ask that you change it, just my tought.

-Remove the notes on the map
-I was out of the sewer after about 5 min of playing, because i’v found a Hacksaw quickly nearby the mine and was able to fallow the path on the left side. Only a few “square of map” later there is an entrance.

Where did you found the hacksaw? Hmm, I don’t remember adding one did the zombies drop it? Cause I never thought of the possibility of using those to escape.

I think Ill need to “Solidify” the obstacles then hehe.

Yeah the notes kinda get in the way of the immersion.

Will work on both of your suggestions thanks.

I like the idea of harder, bigger dungeons.
quietly chants Mod! Mod! Mod!

I had a lot of fun playing this, it was a very refreshing change to play in a different way.

You finished it right? Would you mind giving me some feedback on the difficulty? Was it easy, average, semi-hard?
I would really appreciate it.

I got a little bit stuck in the CHUD camp. There are a bunch of animalskin flaps that open up onto closed metal doors, I can here things moving around on the other side though. Further along there is a corridor blocked by animalskin walls, if you head south, east and then north again you end up in the animalskin wall blockade.

I’m a little confused as to where I am supposed to be going, am I supposed to tear down animalskin walls? I have been s’mashing this thing for about half an hour now, but with no success.


I backtracked and found the way forwards.

I died outside the door I was not supposed to die outside :slight_smile: I was not expecting that.

I will reload the map and try again.


The door part is kinda impossible.

My guns don’t have the strength or range to damage the turrets, add molotovs perhaps? or maybe a stray soldier with a few grenades.

Yeah you were supposed to smash the walls, but theres a glich with them that makes them indestructible if they dont complete a 3X3 square, I already fixed it for the next release.

If you backtrack a bit, youll find a sewer that froks a small distance before the camp entrance, you can also take that route.

Did you found and grab the single barrel shotgun(you can get close enough to blast it with it) or the rifle, if you didn’t, that’s why. Also check your starting equipment.

Yeah I had the single barrel shotgun, but I got shot to pieces by the turrets. I ran out of ammo for the rifle a while back.

You have to be congratulated using the map editor too. Never In my life have I seen a UI so backwards and impossible.
Dwarf fortress is a nice graphical application, that anyone can pick up compared to the “thing” we have for a map editor.

Its just rouge likes being rouge likes, then. there are spots were you can shoot them without them shooting back. Anyways that’s technically the boss fight of the dungeon right now the whole thing ends a single map square ahead. ( I already fleshed the settlement a little more but I will at least finish it before an update)

Thanks, you get used to the editor eventually, but its kinda rough on your hands if you have a laptop keyboard (like I do)

Funny, i didn’t used gun, not at all. I’v just trow everything i was able to found at the turret - and it worked.

For the hacksaw, iv found it on a mine, so must be from a Z (random drop).

Overall i found this really easy but all part with fish - they oftent hit me one or twice before i kill them, but iv ended full life.
(iv deletd the animalskin wall with the editor, because you’v said that should be destroyed)

Yeah, CHUDs are not half as hard as I remember them being, I think ill reduce the amount of ammo a bit (those 50 9mm rounds at start are god mode)

I dedicated a nice chunk of today expanding the dungeon (to the point thaat i almost duplicated the work I have done past week) so I am releasing an update. I think Ill go with weekly bigger updates unless there’s a bug or something like in the previous version.

What changed:
-Changed your starting equipment to make the game slightly harder.
-Removed the glitched animals skin walls.
-Expanded the dungeon
-More Chuds in the Chud camp
-More awesome weapons!
-More poison gas!
-More zombies!
-Added a still unfinished vehicular part because frankly we all want to drive cars on the subway, right?)
-700% more hulks
-1 0f 10 The Walking Dead references added!
-Multiplied the amount of arachnids by infinite (now a fucking lot, before 0)
-Removed the notes in the map
-Renamed the world

Get it Here!

Played it, loved it, wished all subways in the normal game were like this. One thing I noticed though was that when you have to drive the car through the wall, that the car can get stuck sometimes so I suggest that it made just a tad thinner. Also when you reach the forest? tiles, having a path to follow through would be nice and to tone down the number of spiders so it isn’t freaking impossible.

Do You mean The part when your car hits the metal bars? I did that on purpose, the hole dungeon ends there for now: I just decided to be cruel and force you to die :).

Or did you walked through them? Because you are totally not meant to walk through them! Its supposed to be a speed up and hope my engine holds moment! The tunnel keeps going in a straight line though, so you should just try not to hit the walls and you’ll exit the spider nest eventually I guess ill add notes to the map to better symbolize it. Thanks for your time!

I meant the part where you first get the car and there’s a note near the wall that says ‘Bill, drive it through here’ or something along those lines. I’ve had the car break its engine going through or it’ll go through the first time then bury itself in the wall then explode.