Can't fire tank's main gun

So I found a tank on the road and tried to fire the main gun (A 120mm cannon) but instead of aiming it shows the ‘draw from holster menu’. I tried to reload it with some shells but it doesn’t allow you to, instead it gives you the option to either control the vehicle or examine it. Then I tried to debug a tank and the same thing happened, then I tried with other tanks and other armored vehicles but I couldn’t fire their main guns, and even found out that the 30mm chain gun has the same problem as the 120mm, the only mounted guns I could fire were the machine guns.

I think it has something to do with the update #7284 wich added ‘turret mounts’ but I’m not sure, I know I could fire cannons and such some updates before the one I mentioned. This is my mod list:

  • “dda”,
  • “Arts’ Guns”,
  • “craftgp”,
  • “realguns”,
  • “makeshift”,
  • “Medieval_Stuff”,
  • “More_Survival_Tools”,
  • “nw_pack”,
  • “mutant_npcs”,
  • “npc_traits”,
  • “more_buildings”,
  • “Urban_Development”,
  • “boats”,
  • “deoxymod”,
  • “blazemod”,
  • “Tanks”,
  • “no_rivtech_guns”,
  • “no_scifi”,
  • “more_classes_scenarios”,
  • “RL_Classes”,
  • “filthy_morale”,
  • “no_reviving_zombies”,
  • “StatsThroughSkillsFour”,
  • “ZSFIXED_cddaxp”,
  • “more_locations”,
  • “Experimental-Z-Level”

Yeah, I think what you’re basically seeing is a clash between the new implementation of turrets as you said and blazemod’s old turret system. It’s gonna take a while to get it cleaned up.

Is anyone even keeping up with actually maintaining blazemod? I’ve seen some forks but they’re all incredibly outdated (2017/2016) and I know there’s a lot of long-standing bugs regarding manually-reloaded turrets and blob items.

Yeah, I can also chime in with broken turrets and cannons. I was in the process of building a mobile-home-tank from scratch and have been at it for a few days. Took down a tank drone and got its 120mm cannon that I thought I’d add to my tank, but I couldn’t add any cannons or turrets into it. Scraped off some turret mounts from wrecks too, but they don’t work in my tank either.

Tank turrets would be fixed in:

There was really dumb error where copy_from was used instead of copy-from in Tanks mod which I missed while hen testing.

Cheers for the fix. It’s always the silliest issues that go unnoticed.