Can't current load save (again) (Generic Guns)

Welp, it happend again, this time it was the generic guns mod, same old same old, im a dumbass, yada yada.

I fell like im just complaining a lot about stuff i could fix if i knew how to.

Anyways, any help?

Stop updating your game.

Are you using the Generic_Guns mod that comes packaged with each update? Generic_Guns seems to have been modified just yesterday on GitHub, so if you updated the game but you’re using a custom version of the mod then the game might be seeing some data that it thinks shouldn’t be there.

How do i fix it? :((

Without knowing more about your setup I can only make guesses, but it looks like your version of Generic_Guns is from pre-build 10634 and your game is from after. Do you use the launcher to update? It’s possible that the launcher might have put the pre-10634 version back for some reason instead of using the one packaged with the game.

The best way to fix it would probably be to get a fresh copy of the game from the experimental release page and go into your data\mods\ folder, delete the generic_guns folder inside it, then replace it with the one data\mods\ from the new copy.

Replacing the mod from the archive would be a lot more simple, but if you really want to make the changes yourself, do this:

  • Go to data\mods\Generic_Guns\magazines\
  • Open pistol.json, treating it as a text file if prompted
  • Find every line that begins with “delete” and erase the entire line.
  • Above every “delete” line will be another line with a comma at the end. Delete this comma, only this comma, and nothing else. If you leave it the game will produce a different error on loading.
  • Save the file.
  • Open pistol_magnum.json
  • Repeat this process for every line labelled “delete”. Pay careful attention to the changes you make; erase the entire line labelled delete and nothing else and do not forget to erase the comma above each and nothing else.
  • Open pistol_tiny.json
  • Repeat
  • Open rifle.json
  • Repeat
  • Open rifle_huge.json
  • Repeat
  • Open shot.json
  • Repeat

Don’t forget to save each file as you make the changes. This should make it usable, but again, getting a fresh copy of the mod will do the same and is much less work. if something else goes wrong let me know and I’ll try to help.

1 Like

Thanks, it worked :))

but i have another problem, now for some reason, everytime i try to reload my guns, the ammo dissapears, any help with that?

You get a message saying the gun was loaded but the ammo never gets into it? If that’s the case, a similar thing is happening with several types of stoves, as recorded here. I think it’s a bug with nested containers, so it might be best to go back to build 10614 or earlier, before nested containers were introduced.

Of course, that means undoing the changes you made to Generic_Guns, but an earlier version also shouldn’t produce that error. If you want to go back to 10614 or earlier, you may have to ask around on the forums for a copy or a way to get one since the experimental releases page doesn’t go that far back.

1 Like

All releases can be found on github.

An other way to achieve this (although not as reliable) would be to copy a download link from the “Experimental Builds” page suited for your system, edit the two build numbers to change it to the one you want, and then use it in the adress bar of your browser.

Also, the launcher may allow to do this too; I’m not sure as I’ve never used it.

1 Like

Thanks for all your help :)), yeah idk who had the brilliant idea of adding nested containers anyways, if you stumble upon the 10614 experimental version pls let me know

I’ve tried changing version with the laucher, i just doesn’t work…