Can't craft staff sling

I have the skills and components required but the sling component is red text in the crafting menu and it says I can’t craft it.

If it’s red in the crafting menu then the game thinks you don’t have it. Is it out of range? Blocked from your sight by something? Modified in some way?
I can’t see how these would apply to a sling but I know things become unsuitable for crafting if they’re loaded or have a battery mod in or are filthy etc etc.

No, it is withing range and sight. I am going to reinstall the game.

i have the same problem, i think the issue is (haven’t tried it yet) that you have the sling that was crafted from 3 long strings, while the staff sling requires the sling that was crafted with a leather patch maybe??? they have the same name but i think they’re different items

I crafted botht the leather patch one and the string one. Neither worked. I have reinstalled the game and it seems to have remedied the problem. I will also mention that I was getting error notifications which I just ignored and pressed spacebar in the previous install. I have not had error notifications in this install yet.

1 Like

interesting, seems i also have to reinstall the game then since i also have those same error messages lol, are you playing on the same savegame or did it break?

I just started a new game

post a screenshot of how the crafting interface looks, might help

I’ve just tested it, in tiles experimental build 0.E-10527 on Windows 7 64-bit.

  • Spawned sling from the debug menu doesn’t work.
  • Unloaded spawned in sling doesn’t work.
  • Crafted sling doesn’t work (both versions).
  • Crafted and untouched sling (leaving it on a table next to me) doesn’t work.
  • Shooting it once and try to craft with it afterwards doesn’t work.

It states in the item description, that it can be used to craft a staff sling, but it just doesn’t work (even ignoring the red component warning and greyed out name and just pressing enter).
I’ve got no error messages. Freshly generated world without any mods (other than the default no NPC needs).
I suspect the problem to be that it is always “loaded” with pebbles. Is there an other item with the RELOAD_AND_SHOOT flag to prove/invalidate my guess?

I was going to ask for the same thing, but I’ve figured I just test it. It literally is the normal “component not avaiable” red text reading “sling”.

Edit 15. April 2020 08:54 UTC+2:
Welp, it looks like it got fixed. Went to test it again in build 10530 and this bug is gone.

1 Like