Build 6016: Old saves crash on attempt to load, new games crash on save attempt

Running the game through Wine Wine 1.9.24 on Linux Mint Sarah because A: I can use the launcher that way and B: Attempting to install the Linux version has gone poorly in the past. Usually works great, but something in the recent batch of updates seems to have broken something.

Edit: Rollback to 6008 fixes. Rollback to 6009 does not. So whatever broke it must be one of:

[code]Commit 2c08f8519d432752749860ad97f06a362a68b7e0 by mugling
Display localized ammo names in bandolier info (#19625)

Commit adef32a0a67f8bc407ab6f32f4cf00af691ec7af by mugling
Defer autopickup item lookups until first use. (#19626)

Commit 6ddd136357ab1129cac3f795adcb016e7c27907e by mugling
Fix autopickup UI’s "S"witch option, which did nothing. (#19627)
A simple mismatch in the keybinding name used.

Still crashing on load of an old save in build 6017.

Crashes when saving a new game on 6017 too.

Oh good, it’s not just me. Are you running through Wine like me or running through your the version specific to your OS?

I’m just running it through the regular Windows version and it sounds like we’re having the same sort of crashes, so I guess it’s not a Wine/Linux problem.

And does rolling back to update 6008 fix it for you as well? That would seem to confirm that it’s something in 6009 that broke it.

Yes, going back to 6008 fixes it for me.

Yeah, I was playing on build 5991 and just updated to 6017 and now C:DDA crashes (stops responding) when in the “Finalizing and verifying” phase of loading.

Here’s my debug log, in case it helps:

Same issue here, it seems. I can start new worlds and characters and play for a little bit, but trying to load saves is a crash. Auto-saves also seem to cause a CTD. How does one go about rolling back the version? I’m on Ubuntu.

Yeah I had such problems too (Windows btw). If I saved a game and exited and tried to load it would crash, it also crashed sometimes when making worlds.

Just updated to 6020 and it still crashes when trying to load a game…fuck

I use the launcher through wine so I’m not sure how you would do it if you’re just using the Ubuntu version of the game. With the launcher I just scroll down the available builds list and select the build. Speaking of which the launcher is showing me that there’s an update 6021 in the pipe to “Initialize bChar in the auto_pickup ctor”. Since following the issue on the github page seems to show that the fault had something to do with auto pickup once 6021 is available that might fix the bug.

Yeah, works fine with 6008 for me too.

I can get everything working well enough for now by disabling auto-saves and just retrying loading the game. Crashes the first time, works the second.

6021 seems to have fixed it for me.

Yep, looking good now. Thanks devs :slight_smile:

Fixed, thanks.

Same for me, cheers Devs!