Beta Talker error? What is that? How to get rid of?

Using a save game (been playing for 2-3 weeks) on Experimental (win 7, 64x) from past several days gives me errors below. Another save from before the updates - works fine. Tried updates from past 4 days - the only one that loads that save properly is from 6-7 days ago Aug 21, 2021.

Moving around is un-sanely slow (10s IRL/move), usually almost instant.

Message log gives "Remain in place, unauthorized person. Security has been activated x ".
It spawns random concrete wall tiles around me (5-6 of them, then adds more as I pass turns) and tiles with green toxic gas (also 5-6).
There was no such thing around before updating, no security bots or eyebots or anything.

I have NO active Missions in the queue.

Mods, beside default: Speedy Dex, Stats from Kills, Stats from Skills.

Let me know if it’s possible to salvage (i just handcrafted Faraday suit, dammit!)

DEBUG : Tried to use an invalid beta talker.
FUNCTION : talker* dialogue::actor(bool) const
FILE : src/npctalk.cpp
LINE : 1365
VERSION : 506dd5b


DEBUG : Unable to find and assign mission target underground_lab_central_-6W.
FUNCTION : cata::optional<coords::coord_point<tripoint, (coords::origin)1, (coords::scale)2> > find_or_create_om_terrain(const tripoint_abs_omt&, const mission_target_params&)
FILE : src/mission_util.cpp
LINE : 251
VERSION : 506dd5b

1 Like

I’ve had this issue too, had to start a new character. Hopefully it’s fixable so I can go back to my other character at some point.

I doubt it’s related but I’m also using those mods.

Also I’ve never seen the concrete walls or poison gas that you mentioned, but I didn’t try walking around much with the error constantly popping up.

You can make your character playable again by editing the .sav file. I made the line with “queued_effect_on_conditions”: look like this:

“queued_effect_on_conditions”: [ ]

edit: there’s two spaces between the brackets