Segmentation Fault

This has caused my current play through to be unable to load. It saved just as I ran out of charge on a soldering iron and when I tried to reload from the save it did this to me. Is there anyway to save it? Any reasonably easy way because I have zero coding skill.

The program has crashed.
See the log file for a stack trace.
CRASH LOG FILE: ./config/crash.log
VERSION: cfc00fa
TYPE: Signal
MESSAGE: SIGSEGV: Segmentation fault


this seem to agree with me about the cause of the problem:

22:47:53.477 ERROR : src/generic_factory.h:445 [const T& generic_factory::obj(const string_id&) const [with T = overmap_special]] invalid overmap special id “bog”
22:47:55.158 ERROR : src/item_location.cpp:291 [bool item_location::impl::item_on_person::ensure_who_unpacked() const] Failed to find item_location owner with character_id 1
22:47:56.123 ERROR : src/item_location.cpp:291 [bool item_location::impl::item_on_person::ensure_who_unpacked() const] Failed to find item_location owner with character_id 1
22:47:58.964 ERROR : src/item_location.cpp:115 [void item_location::impl::ensure_unpacked() const] item_location lost its target item during a save/load cycle
22:48:00.883 ERROR : src/item_location.cpp:785 [void item_location::deserialize(const JsonObject&)] parent location does not point to valid item

1 Like

These are the last messages in the save file:

“You reload the soldering iron with light battery (high-capacity).”, “count”: 1, “type”: 5 }, { “turn”: 12622456, “message”: “Moving onto this chair is slow!”, “count”: 2, “type”: 3 }, { “turn”: 12622458, “message”: “Moving off of this chair is slow!”, “count”: 1, “type”: 3 }, { “turn”: 12622460, “message”: “You see here 19 pinecones and many more items.”, “count”: 1, “type”: 5 }, { “turn”: 12622461, “message”: “Moving onto this chair is slow!”, “count”: 1, “type”: 3 }, { “turn”: 12622500, “message”: “Saving game, this may take a while”, “count”: 1, “type”: 4 } ], “curmes”: 12622463 }

The full stack trace would usually be helpful to actually track down what happens/happened, as it holds all the crucial information on where it crashes.

As for fixing it, I usually offer to take a look and see if I can fix the save file, but I currently don’t have the time for it, so that would probably take 1-2 weeks until you could play that save again, given that it’s even recoverable…
You could upload it and share it in the hope someone else might be able to fix it before me.

As for the error itself, it sounds/looks alot like this bug report.
This issue also links to another issue which mentions a fix, so you could try that on a copy of your save file and see if you’re able to get it running again.

1 Like

I think my issue is the same. Looking at that other issue it seems like there was yet another one which is also referred to. Maybe some recent change has made this a more common occurrence.

I’ve considered debugging in an NPC and adjusting it to resemble my old character as much as I can but I probably won’t remember that accurately so I’d rather do my best to fix this one if possible. The issue that was resolved talked about changing a value to ACT_NULL or something like that and if I have instructions on what that is I could give that a go.

Where is the strack (stack?) trace that you mentioned kept and can/should I raise an issue on GitHub?

Yeah, sorry, I mistyped, that indeed should have been “stack trace”.

You can find the stack trace in crash.log (if you set up your system to not see extensions it would be just called “crash”) file which you can find in the config folder of your game installation.

Since your issue seems to be the same as the one already on GitHub’s issue tracker, there’s no need to open up another issue for that. If you have additional information, you can/should add them to the already open issue.