Rock forge does not consume charcoal

Since I had a problem of using my rock forge to craft anything (that issue was addressed multiple times, for example here:

I downloaded the latest build yesterday, which worked fine in regards to crafting items. Only now the charcoal stored in it isn’t used up. Also, I get red-on-black screen error messges like this:

DEBUG : can’t set ammo null in Rock Forge as it is not an ammo

FUNCTION : item& item::ammo_set(const itype_id&, int)
FILE : src/item.cpp
LINE : 583

I don’t really mind, because as I said at least the furniture works as a forge now as intended, but I guess it still should be fixed at some point. The error message, if you don’t ignore it, pops up several times during the crafting process. This can be reproduced:
Create a new character
Give yourself the necessary skills, tools and items
Build a rock forge
Attempt to craft something (I tried it with an anvil)
I saw there is a similar post already, [Bug]Charcoal forge doesn't use up charges , but thatw as from 4 years ago and I assume by now the issue at that time would have been fixed.
Version 0.E-3407-g845884a (run on Win XP)

I can confirm this… I’ve managed to make a ton of metal objects that need 400+ charcoal and I’m still at over 1000 charcoal, which is where I started.