Pile of books left on street disappeared

Hi! I’m playing 0.C-18900-g0fcecd9 with graphical tiles on Mac OS X (and loving it – thank you!). I left a huge pile of many dozens of books (the entire contents of a mansion that had a ton of books) on the street next to my welding rig (because I wanted the unmemorized recipes to be nearby while crafting things). Went on a trip and came back and the books seem to have disappeared. I have NPCs turned off and static zombie spawn. Would the rain or snow or some other environmental factor destroy the books and make them disappear? Haven’t seen any monsters in this neighborhood for a long time since I cleared it out.

Basically I don’t know if this is normal or a bug or what. Did some searching on this topic on this forum and elsewhere and saw mention of an “inventory overflow bug” but couldn’t find what that meant or if it could apply.

puts on tinfoil hat

I know what happened to your books. The little people took’em, took’em all! They don’t want you to know stuff, no no no…They want you to be dumb, they want you to stop crafting stuff. Why, you ask? Why else, they are preparing for an invasion! They can’t let you have shiny, strong weapons, or armor, or explosives, of course not! Watch yourself, they will come in the night, when you least expect it. First you will realize that more stuff has gone missing, first clothing, then ammo, food, guns, and when they think you are ready, oh then…then they will come. You will hear their tiny feet on the ground, like a horde of mice or rats, coming for you. When you see them it’s already too late. Run, Johnny, run! Your only chance of survival is to flee from the menace of the little people!

takes tinfoil hat off
I don’t think any inventory overflow bug would apply in this case, considering it wasn’t your inventory, AND that those books were apparently not even in the reality bubble. Maybe you put them somewhere else? Maybe into the welding Rig itself, considering that it has some space to put stuff in it? Weather shouldn’t damage items, acid or lava would though, but those weren’t close I’d imagine. Or maybe you moved the welding rig and it stands on top of the books now.
In any case, I will leave you with this link: https://github.com/CleverRaven/Cataclysm-DDA/issues ; open up an issue if you believe it’s a bug. or you could ask one of us to open it for you, if you don’t want to create an Account. In any case, I’m sorry for your loss, I know how bad it is to loose books, especially since you won’t automatically learn all the recipes anymore.

…Huh. I’ve also had stuff disappearing straight out of my inventory. I wonder if the two are connected.

The little people seem to be the only explanation!
Or maybe it’s there and you can’t see it? Did you use V to confirm it they were there?

I join to the conspiracy! A day before yesterday i was looted a city when i found an unlooted house which i think was already looted by me. I was thinking this house must be just very similar to the one i already looted. But now i think maybe there is a bug, so the game sometimes fail to save the changes when it leaves the reality bubble?

Thank you for the reply; sorry to take awhile to respond. I tried moving the welding rig and nothing was under it. So far this mystery remains unsolved, but I’m just making do without the books, replacing my collection as I can.

I don’t have enough information to judge whether it’s a bug or not at this point… I once did bug testing for a living and know the programmers would need more information than I’ve provided to really pinpoint something.

Thank you again for your answer!

[quote=“StopSignal, post:4, topic:12892”]Did you use V to confirm it they were there?[/quote] Yes, and tried doing a “R” read command while standing in all the squares in the area. I did later on see a gun in a pile of guns slip through a wall in the corner of a room and pop out on the other side of the wall when I tried stacking too many in a corner; maybe this is what happened, only the books popped out on a lower level. I tried going down to the sewer to check but the sewer ends right before that point. I did have a ton of books in a single square.

Could be the map overflow bug. It is fixed since then.
For few versions, map overflow would not happen properly, instead deleting the items.
I don’t see why would it happen to items just lying on the spot, though.

Just had the same happen to me in version 0.C-19867-geeef6c0

Left a pile of books on a table, left for some raiding and the whole pile gone when I returned. Maybe it has something to do with the new book reading system?

Books are rather high value. Could it be just thieving NPCs passing by?

Fahrenheit 451 happened!

What? Serious? :smiley: I’d no idea that could happen… I haven’t seen any npc’s roaming around where I am… then again it’s not too safe during daytime yet… Also this was inside a house… with no broken windows or anything when I returned.