Moving pauses after 5 minutes in game

Hi all, I kind of remember this setting from long ago but can’t seem to track it down. When moving, my game keeps pausing/stopping after 5 minutes elapses on the in-game clock. Can someone remind me how to disable this please and what the name of this feature is?


You may have just entered a new chunk and the game needs to update the reality bubble.

Could be map loading, mapgen or autosave.

Autosave can be disabled in options, but this is generally not a good idea since the game will keep eating more and more RAM until you save, which can be noticeable if you play with z-levels and travel a lot.
It can be set to happen less often, which is safer.

So actually I tracked down the issue, although I’m still not really sure why it’s happening. It only happens when I use my NumPad and it’s on an old bluetooth keyboard I hadn’t used in awhile. If I run it on my laptop with a full keyboard, using the numpad to move works just fine. For some reason, it only happens with that specific keyboard - definitely not the map loading new regions.