Line assertion failure crash

I’m not really sure how to describe this one. It is occurring in my game as I explore a science lab and it occurred when I tried leaving it. I’m not doing anything other than look around and loot stuff. No actions being taken other than movement seem to prompt this. I have two NPCs guarding the entrance to the lab currently and an idling car with no battery just a few paces beyond.

The error reads as such

MinGW Runtime Assertion

Assertion failed!

Program C:\User*****\Desktop\Cataclysm\cataclysm-tiles.exe
File: src/line.ccp, Line 321

Expression:!line.empty() && line.front() != line.back()

Abort Retry Ignore

Ignoring the error causes another message to pop up and for the game to crash. Anyone know what this is about or how to fix it?

Try updating. We fixed a common case for this bug recently.

If that doesn’t work and the bug reproduces easily, you could upload the save somewhere and we’d look into it.

I grabbed the most recent edition of the experimental build about 8 hours ago thinking that an update would be just the thing to solve this. I copy/pasted my world to the new install directory and tried running it. Unfortunately the issue persisted, which is what brought me here.

I can upload the save anywhere you’d like. =) What place works best for you and what format should it be in? .rar or something else?

Any free hosting that doesn’t have too many hoops to jump through is fine.

Does the crash reproduce reliably? What has to be done for it to happen?

If you have a dropbox account or storage area you utilize, I can throw the save file at you there.

The crash is occurring reliably. Reproducing it is… difficult… not because it doesn’t reproduce, but rather because it shows up without me doing anything other than moving around. My current setup has my character and two NPCs near a science lab that a zombie horde is baring down on. I’ve avoided any conflict with the horde and I’ve left the NPCs at entryway to it.

All I’m doing is moving around and exploring the lab. The error doesn’t seem to occur in response to any particular action that I am taking, but rather something that may or may not be happening on the other Z levels. I really don’t know as it tends to pop up after I’ve moved.

Then save probably won’t help.

Without a way to reproduce the bug, we’ll need a backtrace and that requires compiling the game.

Are you playing with z-levels on?

I am yes.

So is there any further information I can give you, and is drop box worth sending the save on? Or is this an unrecoverable situation?

Does the crash reproduce at least semi-reliably?

Like, “wait 30 minutes and it will certainly crash” or “walk north until you reach the music store. in 5 tests, it crashed 3 times”.
If it does, then the save can still be useful.

Oh it definitely crashes reliably in that context. As it stands, my current save gives me about 2-5 minutes of game play before the crash occurs, and that is entirely dependent on how fast I am personally going about doing things. As it stands, the save file I possess is essentially paralyzed by the persistent occurrence of this error. Whatever is causing it is happening very shortly after the load.

I will see if I can narrow down the timing and environmental factors for you. In the meantime, I’m still not entirely sure how you’d like me to get you the save file. Does the crew here maintain a dropbox account I can link to a dropbox folder with the save file, or do you perhaps have a game specific business e-mail I can I send the file to?


So I just played the game a few times to get a feel for the possibilities of the error.

I played once as I normally do, slipping into the lab and looting until the error appeared. I was underground by 1 Z level. It took me roughly 30 minutes in game time for the error to occur. This is pretty much the standard for my crashes.

My second play through involved me attacking the zombie horde south of the lab and then returning to the entrance of the facility. I had a hunch that maybe the game was wigging out on account of one of the zombie types loading improperly. I managed to kill the horde without any sort of incident, but when I returned to the entrance of the surface structure of the lab my game crashed due to the same error as previously. The error occurred much later than I’ve experienced while exploring the lab… over an hour of time in game passed between loading the save, killing the horde, and returning to the outside area of the lab.

On my third play through, I abandoned exploring the laboratory entirely and went back to my outpost/personal base. The error did not occur in this instance. I simply played the day all the way through into the next morning and quit the game without incident.

I did a forth play through to test an idea I had. On the first underground floor of the lab there is a mi-go in captivity. My guess was that maybe one of its sound prompts was causing the issue. I went to where it was held, basically the “east wing” of the lab, and waited around for several in game hours. There was no crash until after I left the room and went into the “west wing” of the lab, where in it occurred during a movement action.

Finally I did a fifth play through, again going into the lab and straight into the mi-go’s room. This time I scavenged through all of the area I consider to be the east wing of the lab. Again, the game did not crash despite the time I spent walking circles and scouring the place, and again, the game crashed due to this error once I was moving around the west wing of the lab.

So… whatever is happening is happening because of the lab, but even then there is a geographic inconsistency. My guess at this rate is that there is something occurring either behind one of the locked doors in the “west wing” or one z level down beneath the west wing. Every time the crash has happened it has happened during movement, so it’s not something that requires my interaction or even line of sight to whatever is causing the error.

I hope this information helps, and I await your response to my proposal for the save transfer.

7z format is preferable.
Upload it on any website that allows free downloads without going through adfly link bullshit (wait time is fine) and post link here.

Alright. Here’s a link to mega. I’m not very familiar with adfly services, so hopefully this fits your criteria. If not, just let me know and I’ll find another place to host it.!hYJlEYaZ!QNAGig3DdePMuNls1DkRM69jB-Qiu5NNN7sxk25VB5M

I did a small field test of my own to see what conditions the error would show up in. I detailed the test in an edit of my previous post. I hope it is of use to you.

Thank you for your assistance and patience in helping me with this.

I ran around in your save, but couldn’t get it to crash.

I’ll just lower the “hierarchy” of the crash so that it gives better message next time. Or simply avoids crashing and acts weirdly. Or starts spamming error messages, thus allowing saving the game and easy reproduction.
Still, I can’t fix it at the moment because I don’t know how to reproduce it reliably.

Well ****. I have wasted your time my friend. I went back to the download section on the main website and checked the tileset directory for windows. It turns out I did the great big idiotic thing and downloaded the file at the top of the directory, 5770, assuming without a thought that such was the latest build since it was on top of the list.

Welp. I’ve made a fool of myself and wasted your time chasing a bug you told me you killed because you had. I downloaded the version at the bottom of the list and ran through the lab, waited around, etc. No crash. No nothing. There was no failed line assertion to be found and no problems to report. The only error that occurred here was an ID-10-T error between the keyboard and the chair.

I am so sorry for leading you on a wild goose chase on account of my own impatience and stupidity. X_X Let me know if I can make it up to you, and thank you once again for having the community’s backs on these matters. Now I’m going to go hide for a few days, lmao.

Take care.