Launcher refuses to update game


#1

For a while the launcher has been consistently stopping the game update process at random intervals. I can’t tell you how many times it has reached 60-99% and then just STOPPED with the “Could not download game” at the bottom. I even downloaded the latest launcher and the problem persists. I get at least 2-3 mbs so speed is not an issue. Mindbogglingly enough it randomly goes through and fully downloads it after dozens of attempts prior.


#2

What’s your connection type? Is it cable or mobile?

There were reports that launcher treats unstable connections poorly:


#3

My way of getting internet on my computer is admittedly… unorthodox as I use my phone as a makeshift wifi dongle for the wifi I have at home. The odd thing is I’ve been doing this awhile and the problem has only shown just recently like a launcher update or two. the last time I remember it working perfectly was before 3.14-15? I think the one where it had the bug where all the options greyed out. I updated the launcher and ever since its been a tad… flighty.


#4

After some investigating it seems that even downloading the game manually is a bit finicky as it stops at similar points yet downloading something else of similar size is fine or even bigger sizes work as well. This is odd as yet again I’ve done this before with the same setup and it worked fine… hmm… guess I’ll look around some more.


#5

It is possible some settings were changed on download server http://dev.narc.ro/ lately, but I am not sure.

Pinging @narc.


#6

Not recently, sorry. It sounds to me more like a security appliance or firewall reacting to something that looks suspicious.

Have you tried downloading from the HTTPS site? It’s literally the same URL, just change it to https:// if it isn’t already. The idea being that a security appliance probably couldn’t (as easily) inspect encrypted traffic.


#7

Fascinating will try now though my launcher has proc’ed the full download and has… greyed out every option and does not proceed… gee thanks launcher real helpful. I press cancel update and options come back but the game is not updated XC. Nope https does not make a difference dang it WAS working like a couple weeks ago