Holsters keep stealing my hotkeys

Every time I unsheathe my arming sword, it switches hotkeys with my light stick. Absolutely nothing I do fixes this, and it is 100% consistent. I’ve had the light stick for literal in game years, so I don’t know why it’s only doing this now.

I’ve tried:
-Dropping both of them
-Dropping one of them
-Changing the hotkeys while sheathed
-Changing the hotkeys while unsheathed
-Swapping the hotkeys myself
-Unbinding hotkeys for both
-Using completely different hotkeys
-Activating the light stick before unsheathing the sword
-Assigning multiple hotkeys to both
-Assigning multiple hotkeys to one, and only one hotkey to the other
-Assigning multiple hotkeys to one, and none to the other
-Dropping the scabbard and unsheathing it from the ground
-Smashing a bicycle to pieces with the sword out of frustration
-Hurting myself in my confusion

This happens with my sword, my pistol, my shotgun, and my rifle.

It’s getting pretty aggravating to have to muck around with the inventory every time I want to turn my light on. I’m not quite to the point of carving open my skull to install a flashlight, but I’m getting there.

Did you update after this PR? It might have fixed or broken it.

Have you tried freezing some frogs?

Just do what I do, and hotkey the holsters themselves. Draw and sheathe items with the 'a’ction menu. It’s ez.

Nov. 4th…possibly not. I’ll do that and see what happens. It’s not as big of a deal as I first made it out to be, but I am paranoid of it causing me to like…eat a purifier when I didn’t want to or something.


Well yes, I do that. I mean, I have to because the item effectively disappears when it’s holstered. But I have to hotkey the item itself so I can easily tell the game what to put IN the holster in case I’m standing next to something else that will fit in it.

Like “Why am I still holding my USP? Oh. I guess there was a Glock on the ground.”

It breaks my entire save file. Good stuff.

DEBUG : Error: data/mods//dda/…/…/json/vehicleparts/faults.json: line 3:10: parsed fault overwrites existing definition

“type”: “fault”,
“name”: “drive belt”,

FUNCTION : bool main_menu::load_character_tab()
FILE : src/main_menu.cpp
LINE : 943

Previous version was apparently 8034. I’ve tried the earliest available version, and the only other version I have (7089), and they’re broken too. So unless I can get 8034 back, that’s several hundred hours dead.

I love it when I try to fix a leaky faucet and end up blowing up the planet. More than a little upset.

…The file path in question doesn’t even exist.

I’m getting an error because a file that doesn’t exist is doing something.

UPDATE: I found the file. It’s not where it says it is. I outright removed the file and now it works. Somehow. Except now I can’t make antiparasitic drugs. Or 2x4s. Okay.

Lo and behold, the hotkeys stay the same now. So there’s that. Hooray…?

Auto hotkeys seem to not recognize the holstered item’s key and will assign that key to an item you pick up, which then changes the holstered items key once you take it out of the holster.
I was having this problem and I ended up just turning off auto-hotkeys and just adding my own as I go along, but I think the holstered items might still sometimes lose their binds. I also just hotkey the holster/scabbard now and not the item, so that’s why I am not entirely sure.
(a)ctivating my (h)olster or (s)cabbard brings up a menu showing what can be holstered, even with just one item available, which prevents holstering of the wrong item, for me at least.