Help CTD and question

While exploring suddenly CTD.
Made several test and discover:

  • CTD always at the same hour and minutes.
  • CTD do not happen if I teleport far away.
  • Debug messages dont help.
    Game dont give report and I m out of options to discover whats happens. Its the second savegame this month that got this bug.
    I know a mod its probably the responsible but without some log I m
    Edit: I load a old save, same CTD. This time I drive as far I can with my group. For my surprise got a CTD. This mean its something or someone in the vehicle.
    Edit 2: After more testing it was the food. I not 100% sure but I think its related to liquid taken in “frozen” state (playing in winter here) and the item thaw in inventory cause crash. Again: not 100% sure.

The game also say there is a bad recipe ID but just say “line 67”.

Now about the question : Game uses cpu minimized, around 10 to 20%. Why? Its turn based.

Windows 7
Athlon 2 X2 260
3 G ram
No money :stuck_out_tongue:

Not a dev.

Cataclysm should work on your older computer, so I don’t think that is an issue. Cataclysm works on literal 15 year old craptop wally world specials running Vista.

Could be a corrupted save file.

Also, I do not think the devs can help if it has something to do with a mod. Especially the ones not bundled with. If you think it is a mod, I would try a game without the mod and go from there. Or find out who is responsible for that mod and track them down.

Also, if this is an experimental version, you might want to roll back to last version that worked. Then update again in a few days.

However… these guys can help you more if you mention what version and list of all mods loaded. They also might want your save.

Thanks for answer.
The save file is a “no no”. More than 1.000 edits in the json and mods plus lewd content.
Like I write above is a food items and I think its a vanilla bug.
But still want an answer from some of the dev about that and also CPU usage on game minimized.

Not a CDDA dev but a developer - Why are you expecting it to use more? Between turns, the games mostly just waiting for player input, there’s not much else for it to do.

My bad english strike again.
No, what I mean is : Why use that much a turn based game? I was expecting some like 1% to 5%.

Its not processing much when not processing turns. And the processing required for each turns depends on things like the presence of monsters and items in your reality bubble, among other things. Even vanilla without much mod has tons of things to process, which can be noticeable when you choose a start like the Overrun scenario which puts you in a place with lotsa zombies and items to process.

20 % is too much if there is no activity. Wonder if there some function that is not completely deactivated like “timed turns” or similar stuff.
This discussion is pure curiosity, not a complain.

Just to be clear are you getting the 20% during the turn processing or when you’re just idle?

Its about what I’d expect for your hardware - Your running a decade old two core processor, so that’s vaguely half the potential thinking power of one core allocated to CDDA. Do keep in mind that if your using task manager, the % utilization in there is not what you might think it is. So that % is not actually representative of real usage.

"Those were reasonably accurate interpretations through Windows 7 and Windows Server 2008 R2. "
I got windows 7.
Palemoon show 0% if I m doing nothing, depending of the page I m visiting.
Libre wolf same thing.
Even some 3d games.
In my opinion its some function that is running, probably something that can be detected only in old hardware. Not a big deal but I was curious if they where aware of that.

Not a developer or programer but if i had to take a guess it probably has to do with audio. Even if you don’t have sound packs installed the game is probably runing checks to see if it should be playing a sound file.

Like heavy breathing when the character is exuasted or car alarms. Its probably playing place holder type files if there’s no soundpacks installed. I mean when you have a sound pack installed its always playing ambient sound files.
Since the game doesnt really seem to be designed to have sound id guess thats where the extra process usage would come from.

1 Like

if im interpreting your problem with the ctd right there’s a few possible reasons i can think of.

  1. If you’ve properly narrowed it down to food thawing check to see if its a modded food item. (if so then it means that the frozen food items file is missing a line of code. Don’t know how cataclysm handels it but that would be a good place to start looking.

  2. This one seems more likely to me. The food was a liquide right? And im assuming it was frozen water taken from a puddle so its not in a container like a bottle or bowel. Then you put it in storage in the vehicle. When it thaws normally it would still be contained. Normally if you have the ice in something that cant hold water when it thaws it spill water on the same tile as the container. my guess is that when the ice thawed the program ran a series of true and false checks and to many variable overlapped at once. Probably had the ice in a npc inventory who was sitting on a seat in a moving vehicle when it melted.

so the game tried to “wet” the npc check if the tile it is on is open air ground or a vehicle then check if there is ground under the vehicle and then spill the water on the ground under the vehicle while simultaneously doing the same for however many instances of the ice there where. And maybe that’s what caused the error

  1. Ice melted and game derped out and tried to place the liquid in a container in the vehicle that cant hold it. Like a chair or box.
1 Like

Thanks for answer. Very complete.
Still got that savegame, I try to find the culprit food this weekend.
As far I remember I take some kind of ice cream from a tube because the container got the SPILL flag. And some weird cheese also from a tube. I dont remember food items from mods and I normally dont edit food.

1 Like

Thanks akrieger for Fix choosing a background sfx using almost 20% of cpu time waiting. by akrieger · Pull Request #62683 · CleverRaven/Cataclysm-DDA · GitHub . Now CPU usage minimized is 0%.
Also, game run a bit better in my Athlon II X2.