Experimental branch - clay kiln doesn't work

Hello everyone,
I started building a typical forge, so I needed a crucible. I built a “clay kiln” (the one that is built from rocks in construction menu). Pottery recipes mention “brick kiln”, but I remember that they were interchangeble in stable. But not in experimental - after I loaded it with charcoal, it still didn’t satisfied recipe requirements.

I decided to run a quick test. I started a new character on stable branch as a blacksmith, added materials and charcoal through debug and it worked just fine, despite recipe still stating “brick kiln as needed”
Here are some screenshots for comparison. (Sorry for ugly slide - I had to deal with 1 attached file for new users limit):

So, is it a bug?
Is it a known bug? Surprisingly, I didn’t find any mentions about it.
I also tried to find any recipes specifically mentioning “clay kiln” in experimental and didn’t succeed.

Might be a nested containers bug. There’s no bug filed for it on the tracker that I can see, either.