[5165] Bug trying to build a charcoal kiln makes an error report

So I was trying to build a charcoal kiln with 40 stones and I get an error: Attempted a recipe with no available components!
And then a block of reinforced glass appears instead.

Tried it 3 times and got the same thing every time.

I’m using windows with tilesets.

I think I’ve seen similar problems when constructing other things.

Trying to make a wood stove causes that error to appear, and a charcoal forge gets built instead.

I tried to build a crate, another error appeared, and a display rack was built instead.

Seems like it is still bugged. I’m on 5174 now and making a makeshift bed gets me a sign.
Not tested on a new save though and only on one that I updated with the launcher.

This seems to be a more general problem with the way constructions are selected from the menu. Building a bed from the menu actually builds a wood stove, for example. The error message is simply a byproduct of the deeper problem since there’s a good chance you’re not going to have the materials for the non-wanted construction.

https://github.com/CleverRaven/Cataclysm-DDA/pull/17487 probably related to this PR and the bugs attached to this. Should be fixed in 5175 and up.