Constant crashes

I played the earlier game some time ago (with Deon’s tileset), but I needed to start playing again, so I reinstalled 0.2 on a new computer (Windows 7).

It works fine until I get halfway through Day 2, and then I can’t play anymore, no matter what I do, because the game crashes every time. I’ve got the automatic saves turned on, so I’ve tried completely different things from the last save, but that makes no difference at all.

I’d also kept a backup save from Day 1, so I loaded that, instead. And that one worked fine for hours until I got to about the same time in the game, then did the same thing, just constant crashes. (I regularly saved out of the game, just in case it was a matter of playing for too long at one time.)

I don’t see any other posts about this kind of thing, so is it just me having problems? This is a new computer, but I’ve been playing games all winter with no other problem.

Turn off automatic saves, it’s buggy.

OK, I’ll give that a try. Thanks!

I hope that’s it, but I wonder why it worked for so long, and only stopped working, in both cases, in the middle of Day 2? I’d really hate to stop playing, but it’s just impossible for me right now. So here’s hoping that’s the problem!

Nope. Unfortunately, turning off automatic saves made absolutely no difference. Any other ideas?

listing actual crash data will help you get help a lot more than a general ‘it crashed’ statement.

Crash data? The game closed, and I got the Windows warning that it was looking into a solution for the problem (which never seems to accomplish anything). What else can I tell you?

I guess I don’t know what you mean.

I started a new character on a new world, so I guess I’ll see what happens with this one. I haven’t made it to Day 2 yet, though.

Edit: This one made it till about 04:49 on Day 3. After that, I can’t seem to do anything without the game crashing to desktop. Different character, different world, but the same problem. The game works fine until then.

I’ve been having this same problem too. I can play just fine for so long, but once the game hits a certain day and time on that character, it just does a CtD. Currently it’s about 3PM on day 2 that kills it for me.

If you want the error window data that pops up I can toss that in too.

That’s very close to the same time - maybe even the exact same time - it happened with my first character, too. Even when I re-loaded a much earlier save (from Day 1), the game still quit working at the same time. Is that more than just coincidence?

With my new character on a new map, though, I get to the early morning on Day 3 (after 04:48 or 04:49) before the game completely stops working.

Elissia, I was finally able to get past this on my second character by leaving the area and holing up in another evac shelter some distance away. I haven’t had any trouble since then, and I was even able to return to the first evac shelter to get my stuff afterwards.

I can’t imagine what the problem was, with two separate characters on two separate maps, but the game is working again for me, for now.

Ive heard that there are various crash bugs related to the NPC’s, their quests, to loading an old save into a new version of cataclysm, and to loading a character profile created in an old cataclysm into a new version of the game. It could be any of those or something else.

My advice: Start with a completely fresh copy of cataclysm and generally avoid spending a lot of time around the NPC’s or disable them all together, see if that helps.

I had the same issues yesterday - was trying to board up windows. Thought it was teh action, couldn’t dig a pit. Thought it was construction, tried to sleep. Tried to walk around - pinned it to a time point.

Solution that seemed to work:

  1. Shift-Z: Spawn NPC
  2. I had also been save-scumming, and copy-pasted the files from my backup into the current save folder. The backup was only about 2-3 game minutes behind where i had been.

Whatever was trashed in the game code corrected itself afterward.

What NPC quest did you have? Perhaps it is the antibiotics one running out, and it crashing due to dropping broken stuff?

Not for me. I did have the antibiotics quest with both characters who had this problem, but I’d already delivered the antibiotics in both cases.

There was a glitch with the second character, as I was coming back to the evac shelter with the antibiotics, but it just put the NPC south of the shelter a ways. I was still able to deliver the antibiotics and get training. (He proceeded to empty his gun at everything in sight, eventually running out of ammo. Then he came back towards the shelter, but vanished somewhere. I never found his body.)

That was the character I’m still playing, the one I was able to escape the crashes by getting far enough away. I couldn’t do that with the first character (which had the NPC still in the shelter, if that matters). But both times, I’d already completed the quest.

I noticed that restarting using the same world map leads to VERY buggy NPC’s. They are allowed to spawn in the same location as a previous one. And that just leads to all kinds of problems. (2 npc’s on top of each other, but I could only talk to one. Debug code killed one, and a different one appeared. Strange, but buggy).

I hope you’ll all be pleased to note that .3 has LOTS of crash fixes.

Hopefully one of those fixes this problem. (No guarantee)

Ooh a new update coming up (Yay! amazing job guys) When do you think we will be able to feast on it ?