Can't use Liquid from Bathtub in crafting

Hi friends, been a while. I decided to get into the game again and I’ve got myself setup in a nice Rural house with 300L of water storage in the bathroom and whenever I try to craft clean water from the water stored in the bathtub the game gets stuck on

“Consume the missing components and continue crafting?
these components are required
water (1)”

And pressing Yes just loops the message again forever. I’m standing right next to the bathtub with a brazier and a frying pan and a 60L container I’m trying to fill with clean water to put in my pantry and I don’t get what is going on. Are bathtubs just useless for storing liquids to craft with?

I’m running Linux_64bit version fe570fa (pulled and built yesterday) with tiles and sound. I tried searching for “bathtub” both on the discourse and issue tracker and I didn’t find anything so I dunno.

1 Like

Have not tried this in a while. But a work around for past bugs, was to use a water container that did work and perform the function in smaller increments. For example: A 1 gallon jug. Common and usually one of those items whoever codes changes would test first to check if everything works. I know for certain that dumping a ton of water into a toilet seems to keep quite a bit if that helps any.

Cheers mate.


Just came to me…if it is rural…drive a truck through the wall and use the vehicle in the mean time? I mean…I concoct some wacky ass ideas. But. It can even be upgraded with lots of tanks and you can add to the sides to block the gaping hole in the wall. :thinking:

Hi, thanks for the idea but I’m playing with the trait that prohibits using vehicles so I’m probably just gonna collect 60L tanks and smash the bathtub for extra space :upside_down_face: