Can't make it past "make" in Debian

This is what I did first without errors:

sudo apt install git
sudo git clone git://
cd Cataclysm-DDA
sudo apt install libncurses5-dev libncursesw5-dev g++ libsdl2-dev libsdl2-ttf-dev libsdl2-image-dev

This is the result of the sudo make… line:

:/Cataclysm-DDA$ sudo make CLANG=1 CCACHE=1 RELEASE=1 TILES=1 SOUND=1 LUA=1 Cannot run an astyle check, your system either does not have astyle, or it is too old. tools/ CCACHE_CPP2=1 ccache clang++ -DRELEASE -DGIT_VERSION -DTILES -DLOCALIZE -ffast-math -Os -Wall -Wextra -Werror -std=c++11 -MMD -D_REENTRANT -I/usr/include/SDL2 -DSDL_SOUND -I/usr/include/lua5.2 -DLUA -I/usr/include/SDL2 -D_REENTRANT -D_REENTRANT -I/usr/include/SDL2 -D_REENTRANT -I/usr/include/SDL2 -c src/sdltiles.cpp -o obj/tiles/sdltiles.o src/sdltiles.cpp:690:22: error: no matching constructor for initialization of 'options_manager::cOpt' display_option = options_manager::cOpt("graphics", _("Display"), ^ ~~~~~~~~~~~~~~~~~~~~~~~~~ src/options.h:42:15: note: candidate constructor (the implicit copy constructor) not viable: requires 1 argument, but 7 were provided class cOpt ^ src/options.h:47:17: note: candidate constructor not viable: requires 0 arguments, but 7 were provided cOpt(); ^ src/sdltiles.cpp:2216:14: error: no member named 'random_shuffle' in namespace 'std' std::random_shuffle( playlist_indexes.begin(), playlist_indexes.end() ); ~~~~~^ 2 errors generated. Makefile:638: recipe for target 'obj/tiles/sdltiles.o' failed make: *** [obj/tiles/sdltiles.o] Error 1

CDDA used to start the first time I installed it. It’s when I tried to get ChestHoleSoundSet soundpack to work and updating to the latest experimental that I stopped being able to start CDDA.

Shit, I forgot to test tiles during last update.

Try without tiles and sound for now

:/Cataclysm-DDA$ sudo make CLANG=1 CCACHE=1 RELEASE=1 LUA=1

:/Cataclysm-DDA$ cataclysm
bash: cataclysm: command not found

:/Cataclysm-DDA$ dir
astyled_whitelist CMakeLists.txt doc LICENSE.txt src
cataclysm CMakeModules doxygen_doc lua tests
cataclysm.a freenode.txt Makefile tools
Cataclysm-DDA gfx msvc-full-features utilities
Cataclysm-DDA.sublime-project obj
cataclysm-launcher json_whitelist
CataclysmWin.cbp data lang SIGNOFF

You forgot ./

[quote=“Coolthulhu, post:4, topic:12325”]You forgot ./

Thanks, that worked.

./cataclysm-tiles is working now.

Shortly after I run make I always get:

Is that important? Can you send me a link with instructions on how to install it and which one to get?

Thanks, much appreciated.