Can't build

Hello, whenever I try to build anything, it says “You cannot build there!” I picked up a welder and wrench, a steel frame, then put batteries in the welder. I then tried to construct a vehicle (*,|) but no matter which direction I select, it gives me this message. I tried going outside, but it gives me the same message.

I then tried to clean a window using the construction menu. Broke a window, it didn’t work. It still says that “You cannot build there!” I looked at the requirements, and it says “difficulty: 0” and nothing else was required except for the steel frame.

So does anyone know the solution? I’m using virtualbox to play the game.

I’m also encountering this issue, trying to build some furniture for my safehouse - a dresser and a bookshelf. I can build it in one specific area inside but I can’t move it out of the area after building, nor can I build it anywhere else.

Terrain derpyness, like how you couldn’t build beds on stone floors.

No, construction has been broken, in one form or another, for a few days. Rolling back construction.cpp, construction.h, and game.h to the last commit on the 21st fixed it for me, but I haven’t tried it since the 25th.

git checkout 1cc9e18d528c08ba4fae658ac23853671b66f030 game.h construction.h construction.cpp

It’s fixed in the most recent commits.

Nope. Still can’t clean broken windows.

Huh, should have been fixed in commit I merged from daftfad a few days ago.

When i download that .zip from github repository does it contain all the recent commitments?

Yeah, it contains all the raw code in the repository.

Well, when i choose to clean a window it prompts me to choose direction and when i try to choose one: “You cannot build there” and i’ve compiled a fresh build a couple of hours ago

Damn… I’ll look into it when I get home, I’ve probably done something dumb.

I hope you’ll let us know when it’s fixed.

fixed. was my fault. was trying to make the code clearer. sorry about that.

well it’s not fixed in current , could you upload fixed construction.cpp or whatever it is?

Merged in the fix.

For future reference guys, you’ll get a quicker response by posting an issue on github when you find a bug - that’ll autoemail the devs. I personally don’t check this forum often enough to find these threads quickly.