Arcana and Magic Items error report

Hello. I’ve been having issue trying to get arcana to work. I keep getting this error report:

DEBUG : Error: data/mods//Arcana/gates.json: line 3:20: must specify either id or abstract

“type”: “gate”,
“id”: “t_archon_pedestral_backup”,
“door”: “t_rock_archon_barricade”,
“floor”: “t_rock_floor”,

FUNCTION : bool main_menu::new_character_tab()
FILE : src/main_menu.cpp
LINE : 781

I’ve tried getting it from github and deleting the old folder to replace it with this one but it still doesn’t work. I even just loaded up dda and arcana with it and it still results in that.

Could it be due to cdda being downloaded via the cdda launcher instead of from the site? Is it that the launcher version is different from the website itself?

You should make a bug report on Arcana’s github

I was planning on doing that eventually if no one knew the solution to it here

The solution is to use compatible game and mod versions. Most of the times it would be latest available for both.

Thanks. Yeah I guess I was using something incompatible with the version of cataclysm that I was using and I just didn’t notice.