0.C-8300-g8f04d11 Bermuda Square of Lag

About the problem.
Travelling around a town and clearing out zeds, I seemed to have stumbled onto a lag zone, where in a wide rectangle if the character steps in, the game would spend upwards of 10 minutes calculating the move before allowing you another turn. Stepping out of the triangle would speed things up dramatically. I have not ventured further into the area as it was quite large and would have taken probably many hours just walking into the epicentre and figuring out what was going on.

As far as I know, I think it is here:

I have tested the northern boundary of this area. I can enter the jewellery store and be fine, but the median for the area is very close. At the time, the top left hand side area was around 10 squares to the left of the manhole at the border of the area. The left hand side seems to go downwards in a straight line as shown in the image. This seems to hold true even in the underground areas. As I’ve tried to access the region from the sewers from the sewer gap near the left of the area’s top left hand corner. The same load seems to appear in the same place underground in exactly the same border.

All you need to do is to just walk into that area to experience the immense loading times. DO NOT USE THE VEHICLE IF YOU DO NOT INTENDED TO GO ALL THE WAY TO THE CENTRE AS IT’S MUCH QUICKER BACKING OUT ON FOOT IF YOU ARE JUST MAPPING OUT THE ZONE.

Some things I think might have something to do with the issue: At first I thought it was just a huge number of swimmer zombies attacking a tank that was causing the issue at the top left hand corner. That is until I lured them out and put them all down and the lag zone still persists. Deep in the area was a single ameotic gel thing monster that usually spawns with a bunch of dead sci/mil/drug bodies. It was quite deep in the zone near the centre. The 2 NPC in that area as far as I know are not part of the problem as I’ve been more or less piggy backing with them through the city, and I’ve noticed them travelling together now for some time and have been quite close to them with no issues before they entered the area. The zone seems mostly devoid of any monsters aside from that blob.

Save file is here: https://dl.dropboxusercontent.com/u/120202176/Cataclysm/Minoa.zip

Here are some things I’ve changed in the game.

Most of the changes are to values like damage, amounts, charges used, and amount of charges and so on. Although I’ve also changed the drops of monsters as well, although having killed a large variety of them with no issues, I don’t think this is a problem.

Couldn’t replicate.
I walked around that zone for a while, but the worst thing that happened was a single occurrence of 3 second lag due to something loading-related.
Same 3 second lag happened after I tried again, but that’s it - just 3 seconds once per save.

Scanned the area for weird stuff. The worst cause of constant lag that I see there is moderate number of zombies and some sewer critters in the same reality bubble, but that should be nowhere near that bad.
Then there is debug log filled with tons of “empty spawn location for CHUD” and “empty spawn location for SEWER”, but those should only happen the first time the location is loaded and likewise shouldn’t be anywhere near that bad (though they CAN be quite bad). Some amount of empty spawn locations are to be expected.

Try turning debug mode next time this happens, then checking config/debug.log for anything weird. If debug.log quickly (few minutes of playing) grows into 5+ hundreds of MB, that may also be considered weird.

Finally, check common hardware stuff, like memory usage and hard drive usage. If you don’t have autosave on, DDA can reach arbitrarily high memory amount as all maps are held in memory and only dumped to HD on save. Any save will clear the cached maps - doesn’t need to go back to main menu.

Alrighty, going to give this stuff a try tomorrow.


I took your suggestion that it might have something to do with the game’s saving mechanics, so while I stood inside the zone, I saved, and the whole shebang went away.