Vehicle Won't Move - Help?

So, I recently put together my first mobile command center sort of vehicle, and was very disappointed to find that it won’t run. I was hoping to get some suggestions from people.

Link to picture of vehicle:

I’m very much confused by it, because while the vehicle doesn’t move, the actual speed number (one on the left) will increase, and the tiles turn as if the vehicle were turning. Link to picture of those happening:

Occasionally the vehicle will move, but it’s usually when I reload the game (vehicle will be in a different spot) and I’ve been getting a fair number of error messages regarding the vehicle, so I’m not sure if this is something I’ve done wrong building it or if it’s a bug. Other things I thought I should mention are that it’s being powered with large electric motor(s) (I’ve tried different numbers of motors to solve this) and a wide number of different wheel quantities/locations. Still nothing though, so any advice you could give I’d really appreciate!

Engines too weak, maybe? Try adding a combustion engine.

Maybe you need gas.

I shouldn’t need gas, all my engines are electric. I’ll try putting in a combustion engine later today and seeing where that gets me, though. Thanks.

Probs too heavy. What do you have on it?

Could it be that the battery is out of juice? Or maybe the engine is destroyed(grayed out)?

Cruise control on?

as good a guess as any,

Pssssst, a it won’t run 69 electric large engines on 3% of a bike battery.

Cruise control was on, batteries were fully charged, and everything was at 100% in terms of repair.

As far as being too heavy… I should say I’ve resorted to cheating on a backup save at this point, I just want the thing to work. But I’ve installed three V12 engines, the gasoline to fill the tanks (I put it in the tank, too!) and any configuration of (armored) wheels you can think of, and it does not run. It says it’s going at over 300mph, but all I see is smoke coming from the back of the vehicle and no moving forward.

I’m not continually pressing s either, I promise. I’ve driven vehicles before - made my own before, even - I just can’t figure out why this particular one doesn’t run.

Perhaps it’s stuck on a hand break…


Just tried pressing ‘s’ then accelerating a couple times, no luck. Is there some key related to the handbrake that I’m missing? :confused:

Weeeell that’s definitely a bug then. May wanna upload the save for devs and whatnot to peek at.

May wanna post potential bugs in the Garage, too.

Yeah, this topic really should’ve been posted in the bug reports board to begin with,

Two options I see:

1: Driving skill too low? You seem to be constantly fumbling.
2: It might literally be stuck on something. Check the whole area of the vehicle for odd terrain elements.

There are other options, but if the vehicle is tossing out errors when you load it, it’s probably the second one.

You should post the save with it so that people can test it out.

Turn off cruise control.

Almost certain it’s a bug now. I got this message when I tried to drive again today:

DEBUG: displace_vehicle our_i=-1
Press spacebar…

So I guess that’s it then. Thanks for the suggestions and the topic move, though - I assumed that I was noobing something up, so I didn’t put it in the garage.

EDIT: On an up note, I just walked out of the survivor shelter in my new world to discover an almost completely intact APC. I think I’ll be able to cope with the loss of my fortressmobile. :smiley:

Just open debug, spawn in the parts, remake it, destroy the old one?

this has actually happened to me, and is why I can’t get my beyond massive vehicle to budge.

Belenos here is the save you wanted.

Nevermind its not updating graphicly, even though according to the game I am moving. Have to save and reload in order to see where im at…