Swamp Water?

does water from swamps (and no , not salt water) not count as water for crafting recipes ? because it doesnt count for me
i tried having an empty container and a full one , 2 empty ones and standing near water source
nothing , i have a fire and a cooking tool but the water isnt there


It should count. Works for me. I’m on 5864.

I’m having the same issue, version 5881. The swamps I’m getting water from are salt water, but I can’t use it to make salt, or other recipes that use salt water. I just downloaded and tried it with 5924 off of the same save, with the same results.

Oh, with some further testing, it’s not swamp water that’s causing this problem, it’s being in the swamp that’s causing the issue. If you take water from the swamp, and then leave the swamp with it, it shows up in the crafting screen, but walk back into the swamp area, and suddenly according to the crafting screen, you don’t have that ingredient. As long as you’re in the swamp, you can’t use water for crafting. And I had the same thing near a river too.

Aha, or specifically, if any pool of swamp water (or apparently river water, perhaps other sources) is within the range that you can take crafting supplies from, then it shows you as not having any water/salt water to use in the crafting screen.

i think i got it , the game doesnt register you having both water in the container AND water from normal sources so it decides you dont have anything
try only having one of those