Starting Cataclysm on Fedora 20 - Missing libraries: [FIXED]

[NOTE: Issue has been resolved.]

I’m having a few issues getting the game to run on a fresh installation of Fedora 20. First, I tried just downloading the stable version-- and proceeded to run into the following error:

./cataclysm: error while loading shared libraries: cannot open shared object file: No such file or directory

I’ve attempted installing the lua libraries in both 64-bit and 32-bit, as well as the compat-lua libraries in both 64-bit and 32-bit using yum. The issue still persists.

After roughly three hours of working on this I changed methods and decided to compile it instead, by using git and make. Git proceeded nicely, but when I attempted to use make, the following occurs:

g++ -DLOCALIZE -Wall -Wextra -g  --std=c++11 -MMD -c src/wish.cpp -o obj/wish.o
make: g++: Command not found
make: *** [obj/wish.o] Error 127

Somehow I feel that the solution to both problems is going to be simple, and I’ll feel stupid for not seeing it before, but at the moment I’m entirely new to Fedora, and would really appreciate some help from anyone willing to give it, regarding either (and preferably both!) issues. I suppose that’s all.

Depending on what you’re trying to build, you might also need SDL2, SDL2_ttf, SDL2_image, SDL2_mixer, liblua5.1 and probably something else I forgot about.

Thank you for the help. Got all of those, except for liblua5.1 … Which is difficult for me to find.

Now I’m getting this error when I use make. Again, with a fresh pull from the main repo.

g++ -DLOCALIZE -Wall -Wextra -g  --std=c++11 -MMD -c src/wish.cpp -o obj/wish.o
In file included from src/color.h:8:0,
                 from src/damage.h:5,
                 from src/material.h:7,
                 from src/mtype.h:14,
                 from src/game.h:4,
                 from src/wish.cpp:1:
src/cursesdef.h:10:24: fatal error: curses.h: No such file or directory
     #include <curses.h>
compilation terminated.
make: *** [obj/wish.o] Error 1

You need ncurses-devel.i686 or ncurses-devel.x86_64
liblua5.1 is provided by lua-compat, but I seem to recall having to do something weird like tell it where it was when running the game.

That worked. Thank you, and I appreciate the help.

Woo yea! This should be less of an issue in the future, for release builds (including experimentals) we’ve switched to static linkage, so those executables have no dependencies other than the system libraries.