[SOLVED] Various Bionics Missing And Cannot Be Spawned

Was trying to spawn bionics for a character earlier, and I noticed that only a small amount of the bionics had spawned. I thought this was odd, but didn’t think much of it. I tried to spawn them again, and the missing ones still wouldn’t spawn. Created a blank character on an unmodded world, and the bionics in question still couldn’t be spawned. I’m assuming its either an issue with either the current experimental build (2021-05-20-2005), or some kind of mod issue that has decided to delete a bunch of bionics from the game files. I rarely manage to find bionics, so that’s not my primary concern. My concern is that this could be happening to other items as well, and I would be none the wiser.

Attempted downpatching (to 2021-05-20-0609), but the issue was not resolved. I’ll attempt a fresh install whenever I get the chance and post an update on whether that fixed it (meaning it was a mod issue) or didn’t (meaning it’s likely an issue with the recent experimental builds).

UPDATE: Confirmed to be a mod issue of unknown origin. Read replies for more details.

UPDATE 2: As was probably expected, the issue was my own stupidity. Dark Skies blacklists a bunch of things, including most CBMs. However, it seems to have a bunch of other issues, such as the blacklist being in effect until you restart the game. I’ll open that as a separate thread, however.

What do you mean by “only a small amount of the bionics had spawned”? How did you try to spawn them in and which bionics are missing?

In case you’ve just updated your game version (from a really old one) and are looking for Solar Panels CBM as an example; a lot of bionics got moved over to the Aftershock mod.

By “only a small amount of the bionics had spawned,” I meant that of those that I attempted to spawn using the debug menu, only a few actually appeared in my inventory/on the ground. This includes using the spawn menu to spawn the items and the map editor to place the CBMs on the ground. The result was the same with both, as only the same few spawned.

However, I just did some more testing and can confirm that it’s some kind of mod issue. (Despite the fact that I had restarted the game multiple times during previous testing,) The CBMs now spawn fine on the unmodded world, despite having changed nothing.

Here’s the list of CBMs that will spawn (was a bit too much to type).


Here’s the mod list, if that helps at all:

I haven’t had the time to check your modlist yet, so I’m glad you were able to solve this yourself.

Yes, every mod stays “loaded” for some reason, so you’ll have to restart the game if you want to switch to a world with other/less mods (otherwise it will lead to a lot of “id not found” errors).
I think it’s a known issue and somewhere on the issue tracker on GitHub already, but I’m not 100% sure.

Ah, thanks for the info. Wasn’t aware that was an issue, nor that it was already known about. I’ll check to see if it’s already been reported on the issue tracker, and if it hasn’t I’ll post it myself.