Save crashing on load(resolved)

0.C stable, SDL, Windows 7.

When I try to load my current save, it crashes before it finishes loading. I don’t have the faintest idea why, and don’t know how to recreate it besides my save file… The only things that I can think might be relevant are that I saved in a vehicle, and nearby a tile that has both graffiti and an empty sign on it.

(sorry, there’s a lot of map data so it takes awhile to load)

Ok I think I found something (hopefully) more meaningful.
"Exception at 0x00624DD1 in cataclysm-tiles.exe: 0xC0000005: Access violation reading location 0x0000002C."
Does anyone understand what this means?

Please try the newest experimental version, it includes the fix for this specific bug. You can simply copy your [tt]save[/tt] folder to the new version.

Thanks for your bug report.

The newest experimental (tiles 2943) crashes before it even starts. But thanks for letting me know that this specific bug has already been acknowledged. I’ll try some of the less recent experimentals and see what happens.

2943 crashes for me, too.

Same here - both console and tiles build.

EDIT: 2942 works for me.

2942 works for me, too. Making an issue on git presently.

I went with… urr. a random one further up on the list. My main page says version 436fecb(EDIT: it’s 2940). It works, but there’s been a few things I’ve noted, big and little.

  1. Frankly, and sorry to the person who took the time to code it, but I strongly dislike how encumbrance is reworked. It’s confusing, and simply more unforgiving. I guess I can get over it with time, but I just wanted to state my opinion on it. 2: This one is actually a bug, but it doesn’t even show my traits in my character screen, nor does it implement them. For example, my character has self aware, yet… isn’t self aware right now. 3: It’s been loading slower. Granted, I have larger town and higher zombie spawning options… but it’s been slower compared to the stable.
    Is there a more stable experimental?

Uh, we’re at 2951/52 last I checked. Those working?

Yeah, 2952 works. But my character still doesn’t have any traits.
I guess somewhere along the way of changing versions, my character file must have gotten bugged or something. I guess I’ll just have to do some genetic modifications to replicate the original… using my own link in the original post as a reference.

EDIT: Like I thought, somehow all my mutations just got deleted in my character’s save file. Odd. Oh well, I fixed it and I’m good to go. Thanks guys.