Resuming item being crafted on a table/workbench

I used to be able to resume an “in progress” item being crafted by examining a table/workbench/etc, but I can’t do this anymore.
Is picking an “in progress” item the only way to finish crafting it?

(e)xamine the workbench where the project is and it’ll give you the option to resume.

  • Shane

Which version are you playing on and what are the exact steps you do?
I’ve just tested this in 0.F experimental build 2021-09-17-2330 and it worked fine:
I’ve started crafting a boring sandwich on a table and stopped it midway. [e]xamine the table gives me the option [4] Work on craft or disassembly, and selecting this options list the item(s) in progress. I can then continue working on it just fine (on the table).

However, [a]ctivating the item instead of examine it (or rather the table it sits on) will pick up the item.
Also, the item in progress has to be on the table. Just having it in the characters inventory and examine the table will not work (and never did, if I remember right).

Could it be that you no longer have the ingredients to continue crafting?

  • OS: Linux
    • OS Version: LSB Version: n/a; Distributor ID: ManjaroLinux; Description: Manjaro Linux; Release: 21.1.2; Codename: Pahvo;
  • Game Version: 0.F-2729-g6b325a91eb-dirty [64-bit]
  • Graphics Version: Tiles
  • Game Language: System language []
  • Mods loaded: [
    Dark Days Ahead [dda],
    Blaze Industries [blazeindustries],
    No Hope [no_hope],
    No Fungal Monsters [No_Fungi],
    Fuji’s Military Profession Pack [fuji_mpp],
    No Fungal Growth [no_fungal_growth],
    SpeedyDex [speedydex],
    Stats Through Kills [stats_through_kills],
    Stats Through Skills [StatsThroughSkills]
    ]
  1. I begin crafting.
  2. I stop crafting.
  3. I examine “e” the workbench.
  4. A list of items I can pick up shows up, including the “in progress” item.

No.
I didn’t get a window pop-up telling me what’s missing.

This sounds like the old behavior of [e]xamine.
If you pick up all the items on the workbench and try to [e]xamine again, does it show the table menu?:

I also know some other things to do at the workbench...

If it does not, you might have (maybe accidentally) rebound the e key to pickup items instead of Examine Nearby Terrain.
If it does, there might be something wrong in the order it handles stuff (as if it tries to pickup before checking for special interactions). Which would be really weird, since I can not reproduce this on Windows 7 64-Bit, and I doubt that something like this would be operating system specific…

Another possibility would be that one of the mods redefines the possible actions on a workbench.

The keybind for “Examine Nearby Terrain” is “e”.
I cleared the workbench of all the items.
I examined “e” the workbench and nothing happens.
All the mods I’m using come with the latest experimental.
I’ll report this on GitHub.

I’m pretty sure No Fungal Monsters is marked obsolete… Although that’s (probably) not what’s causing the problem.
I’ve just tested it with your mods setup and can reproduce the bug. So it’s extremely likely caused by one of the mods.
I suspect either No Hope or Blaze Industries

Edit:
Tests completed, the mod No Hope breaks this function.

I linked this reply to the GitHub issue.

No Hope isn’t breaking the function, it deliberately turns it off.

“I used to be able to resume an “in progress” item being crafted by examining a table/workbench/etc, but I can’t do this anymore.”

If something worked and now no longer does, it means it was broken. For my statement it doesn’t matter if it was broken deliberately or not…

It’s my fault that I didn’t specify that:
“I used to be able to resume an “in progress” item being crafted by examining a table/workbench/etc, but I can’t do this anymore.”
without the No Hope mod.

In this game, I enabled the No Hope mod and I really didn’t expect that both existing and player crafted working surfaces would not work.

Anyway, it will be fixed if/when New pickup menu in the style of the multidrop menu by mqrause · Pull Request #51033 · CleverRaven/Cataclysm-DDA · GitHub get merged.