Problem with save file

Hello , as mentioned in the title , I have a problem loading my save file after yesterday. I am now loading in the middle on a ocean/river and the area I was at on the map tile (‘m’) are all unexplored. This is the message I received, although I can’t make sense of it >.<

DEBUG : Failed to read from “./save/Holcut/o.0.0”: line 24:821753: missing separator


FUNCTION : bool read_from_file(const string&, const std::function<void(std::basic_istream&)>&)
FILE : src/cata_utility.cpp
LINE : 436

It looks like something corrupted a portion of your save file. I don’t know how it works for map files, but, before they added checks for it, a missing separator would cause the file to stop loading at that point, but not cause a fatal error, leaving you to deal with the consequences of that missing data. This would lead to weirdness like the definitions for items and recipes disappearing, leaving you with an inventory full of broken items and a screenful of debug messages.
Does this message kill the world load (I think no, but want to be sure)? What happened yesterday? Did you update you game, did you have a crash during a save? If you want to try a brute force approach to fixing it, get a text editor that shows line and character numbers, like notepad++, and navigate to line 24, character 821753 and see if you can’t replace that missing separator. It may not fix all your problems if you’ve gota corrupt save, there could just be data missing. But getting the format correct should let it load without error. In this case, the separator would mostly likely be a comma.

It doesn’t but I am spawning in very weird places , and my previous location is unexplored in the map tiles. My inventory and status screen are still the same.

The only thing I can think of was that I changed my Suicide keybinding to the Debug menu, then i tried a short teleport, and unbind the key again.
Or maybe because I accidentally off my computer before closing the game (Although I did save successfully)

How do you know where to place the separator at? And where do you get the line and character numbers from?

the line I quoted above is the most informative line in the whole message. It tells you which file, where inside the file and what the issue is.
The bit below that that’s all [12,12,-1],[250,2,0], etc… is a snapshot of the portion of the file with the error. Oddly, it doesn’t show the exact location of the missing separator, but that’s probably because of how big the file is. The section below that is helpful if you understand C++, it tells you what portion of the code tripped the debug message. Not really relevant for most people.

This “line 24:821753” is the portion that tells you where the problem is located inside the file. Line 24, character 821753.

I imagine if you save the game after loading into the weird place it drops you, that will probably fix things, but you’ll be stuck dealing with the problems. I think the best bet would be to try fixing that file, hopefully it’s just like it sounds, a missing separator. Alternatively, you could try transfering your character to a new world and starting over.