Mods causing startup crashes

just putting this here as a ‘wait what?’ but i was having issues with the current version loading up to a black screen until i removed 3 mods

… two of which are yeaokaywhatever:
uekibati_mod: which had something to do with pots for growing things
Whaley_Hair_&_Tattoo: self explanitory

but the third mod that was making it crash was dda, as in the folder that just contains the JSON that activates the core content. whot?

You are probably using incompatible game and mod version. You need to fix mods to make them compatible with your game version.

yes i realize that, which is why i was removing mods to get it to work again.

but why was dda, which is basically a mod included in the main game, one of the issues?

No way to tell without seeing the actual error message.

Perhaps you had a cataclysm binary that doesn’t match the version of the json folder? I get a similar result if I check out a different version of CDDA from git and forget to recompille the binary to match.

the debug log: (edited every @ because the forum thinks i’m trying to @ people.)


01:20:46.959 : Starting log.
01:20:46.959 INFO : Cataclysm DDA version 0.E-8333-gf4ad3b9
01:20:46.963 INFO : [main] C locale set to C
01:20:46.963 INFO : [main] C++ locale set to C
01:20:46.963 INFO : SDL version used during compile is 2.0.5
01:20:46.963 INFO : SDL version used during linking and in runtime is 2.0.5
01:20:47.091 WARNING : opendir [./sound/] failed with “No such file or directory”.
01:20:47.427 INFO : Number of render drivers on your system: 4
01:20:47.427 INFO : Render driver: 0/direct3d
01:20:47.427 INFO : Render driver: 1/direct3d11
01:20:47.427 INFO : Render driver: 2/opengl
01:20:47.427 INFO : Render driver: 3/software
01:20:47.430 INFO : [options] C locale set to C
01:20:47.430 INFO : [options] C++ locale set to C
01:20:47.449 INFO : Active renderer: 0/direct3d
01:20:47.704 INFO : USE_COLOR_MODULATED_TEXTURES is set to 0
01:20:47.713 INFO : Language is set to: ‘en’
01:20:47.713 INFO : [translations] C locale set to English_United States.1252
01:20:47.713 INFO : [translations] C++ locale set to C
01:20:47.962 ERROR : (error message will follow backtrace)
(dbghelp: @ 0x6a5996[cataclysm-tiles.exe+0x2a5996]),
(libbacktrace: Z21debug_write_backtraceRSo+0x56 @ 0x6a5996),
(libbacktrace: 0x6a5996 [unknown src]:0 [unknown func]),
(dbghelp: @ 0x6a63d6[cataclysm-tiles.exe+0x2a63d6]),
(libbacktrace: Z8DebugLog10DebugLevel10DebugClass+0x2f6 @ 0x6a63d6),
(libbacktrace: 0x6a63d6 [unknown src]:0 [unknown func]),
(dbghelp: @ 0x6ab120[cataclysm-tiles.exe+0x2ab120]),
(libbacktrace: Z12realDebugmsgPKcS0_S0_RKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0x50 @ 0x6ab120),
(libbacktrace: 0x6ab120 [unknown src]:0 [unknown func]),
(dbghelp: IMG_LoadWEBP_RW+0x11e074 @ 0x1473364[cataclysm-tiles.exe+0x1073364]),
(libbacktrace: Z12realDebugmsgIJPKcEEvS1_S1_S1_S1_DpOT_+0x344 @ 0x1473364),
(libbacktrace: 0x1473364 [unknown src]:0 [unknown func]),
(dbghelp: @ 0xc414ac[cataclysm-tiles.exe+0x8414ac]),
(libbacktrace: ZN11mod_manager12load_modfileERK10JsonObjectRKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0x1dc @ 0xc414ac),
(libbacktrace: 0xc414ac [unknown src]:0 [unknown func]),
(dbghelp: @ 0xc4237c[cataclysm-tiles.exe+0x84237c]),
(libbacktrace: ZZN11mod_manager13load_mod_infoERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEENKUlR6JsonInE_clES9_+0xac @ 0xc4237c),
(libbacktrace: 0xc4237c [unknown src]:0 [unknown func]),
(dbghelp: @ 0x566157[cataclysm-tiles.exe+0x166157]),
(libbacktrace: ZNSt17_Function_handlerIFvRSiEZ28read_from_file_optional_jsonRKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEERKSt8functionIFvR6JsonInEEEUlS0_E_E9_M_invokeERKSt9_Any_dataS0_+0x87 @ 0x566157),
(libbacktrace: 0x566157 [unknown src]:0 [unknown func]),
(dbghelp: @ 0x56a5d3[cataclysm-tiles.exe+0x16a5d3]),
(libbacktrace: Z14read_from_fileRKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEERKSt8functionIFvRSiEE+0x143 @ 0x56a5d3),
(libbacktrace: 0x56a5d3 [unknown src]:0 [unknown func]),
(dbghelp: @ 0x56a96d[cataclysm-tiles.exe+0x16a96d]),
(libbacktrace: Z28read_from_file_optional_jsonRKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEERKSt8functionIFvR6JsonInEE+0x6d @ 0x56a96d),
(libbacktrace: 0x56a96d [unknown src]:0 [unknown func]),
(dbghelp: @ 0xc3e653[cataclysm-tiles.exe+0x83e653]),
(libbacktrace: ZN11mod_manager13load_mod_infoERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0x83 @ 0xc3e653),
(libbacktrace: 0xc3e653 [unknown src]:0 [unknown func]),
(dbghelp: @ 0xc3ea2b[cataclysm-tiles.exe+0x83ea2b]),
(libbacktrace: ZN11mod_manager14load_mods_fromERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0x4b @ 0xc3ea2b),
(libbacktrace: 0xc3ea2b [unknown src]:0 [unknown func]),
(dbghelp: @ 0xc3ff9d[cataclysm-tiles.exe+0x83ff9d]),
(libbacktrace: ZN11mod_manager16refresh_mod_listEv+0xcd @ 0xc3ff9d),
(libbacktrace: 0xc3ff9d [unknown src]:0 [unknown func]),
(dbghelp: @ 0xc44265[cataclysm-tiles.exe+0x844265]),
(libbacktrace: ZN11mod_managerC2Ev+0xd5 @ 0xc44265),
(libbacktrace: 0xc44265 [unknown src]:0 [unknown func]),
(dbghelp: @ 0x11a66f9[cataclysm-tiles.exe+0xda66f9]),
(libbacktrace: ZN12worldfactoryC2Ev+0x79 @ 0x11a66f9),
(libbacktrace: 0x11a66f9 [unknown src]:0 [unknown func]),
(dbghelp: @ 0x7e64b7[cataclysm-tiles.exe+0x3e64b7]),
(libbacktrace: ZN4gameC1Ev+0x957 @ 0x7e64b7),
(libbacktrace: 0x7e64b7 [unknown src]:0 [unknown func]),
(dbghelp: IMG_LoadWEBP_RW+0x7c68ba @ 0x1b1bbaa[cataclysm-tiles.exe+0x171bbaa]),
(libbacktrace: main+0x106a @ 0x1b1bbaa),
(libbacktrace: 0x1b1bbaa [unknown src]:0 [unknown func]),
(dbghelp: @ 0x4013ed[cataclysm-tiles.exe+0x13ed]),
(libbacktrace: tmainCRTStartup+0x23d @ 0x4013ed),
(libbacktrace: 0x4013ed /home/narc/src/mxe/tmp-gcc-x86_64-w64-mingw32.static/
/mingw-w64-v5.0.2/mingw-w64-crt/crt/crtexe.c:336 _tmainCRTStartup),
(dbghelp: @ 0x4014fb[cataclysm-tiles.exe+0x14fb]),
(libbacktrace: WinMainCRTStartup+0x1b @ 0x4014fb),
(libbacktrace: 0x4014fb /home/narc/src/mxe/tmp-gcc-x86_64-w64-mingw32.static/
/mingw-w64-v5.0.2/mingw-w64-crt/crt/crtexe.c:186 WinMainCRTStartup),
(dbghelp: BaseThreadInitThunk+0x14 @ 0x7ffa89c97c24[KERNEL32.DLL+0x17c24]),
(backtrace_syminfo failed: errno = -1, msg = no symbol table in PE/COFF executable),
(backtrace_pcinfo failed: errno = -1, msg = no debug info in PE/COFF executable),
(dbghelp: RtlUserThreadStart+0x21 @ 0x7ffa8af2d4d1[ntdll.dll+0x6d4d1]),
(backtrace_syminfo failed: errno = -1, msg = no symbol table in PE/COFF executable),
(backtrace_pcinfo failed: errno = -1, msg = no debug info in PE/COFF executable),
Backtrace emission took 1 seconds.
(continued from above) ERROR : src/mod_manager.cpp:216 [void mod_manager::load_modfile(const JsonObject&, const string&)] there is already a mod with ident dda
01:20:52.390 : Log shutdown.

and the .json that caused it: (worked just fine after i removed it)


“type”: “MOD_INFO”,
“id”: “dda”,
“name”: “Dark Days Ahead”,
“description”: “Core content for Cataclysm-DDA”,
“category”: “content”,
“core”: true,
“path”: “…/…/json”,
“legacy”: “…/…/legacy”

the ‘problem’ its seemingly coming across is that ‘theres already a dda’, except the .json just redirects it to the existing dda.

I’m getting that black screen too-- unintuitively, can you hit space a couple/few times and does it eventually go to the main screen?

mine wasnt, no, but after i checked the debug a few times to see which mods were causing it (namely, those listed above, they usually came at the end of the debug log so i just removed them one by one) it worked. try it.