Main menu language

I found that main menu and some others words still english even if non-english lanugage choused in game settings. Also seem like cdda get envoiromentals vars and try get LANG var and after it load those settings-independent words. Is there way to fully set settings language for whole game or way to make game load non-english language as main language ?

Russian has the full screen translated

But several other languages appear not to (probably because they don’t have full coverage, like Russian does).
You can see the coverage of each language at Transifex, and see if your language has full translation.

System language is set by default. If there is translation for this language this translation will be used. If there are strings missing in translation, original English strings will be used.

You can also select translation language explicitly (for sanely full translations) in settings menu.

I have russian language choused in settings and ru_RU.UTF-8 seted as LANG (linux env vars) but i still have english menu

It’s possible you don’t have an up to date mo file for your language.
If you have the git repository, you can run lang/ to compile the po files into mo.