Latest build Win32 #390 crashes at startup

As the title says. Runtime error appears and it had to terminate the program. The non-SDL version. The latest SDL version works fine but the curses version not.

This log is under “view problem details”:

Problem Event Name: APPCRASH
Application Name: cataclysm.exe
Application Version:
Application Timestamp: 524e17bd
Fault Module Name: cataclysm.exe
Fault Module Version:
Fault Module Timestamp: 524e17bd
Exception Code: 40000015
Exception Offset: 002d3d15
OS Version: 6.2.9200.
Locale ID: 1033
Additional Information 1: f90f
Additional Information 2: f90f620ebafd2d056113aac78ccb7477
Additional Information 3: a77b
Additional Information 4: a77b291aa1da7f70820839889bec9f9f

EDIT: build #389 didn’t work either. Latest build that worked for me was #386 (non-SDL)

I’m getting the same thing, for what it’s worth.

This should be fixed in the next merge.


Merged 1942rob’s fix, please download and test so that this fix can be widely confirmed :smiley:

I confirm that the fix fixes the error. Thanks, Rob!

Fixing crash-bugs is (somewhat) fun :slight_smile:

Was this merged into the Git repo? I just downloaded the latest build, it compiles without issue, but I get a segfault on startup. I’m on a Mac trying to use the curses version, but I’m wondering if this bug applies to all builds.

Try pulling this:

It looks like this doesn’t fix it for me. I tarred up my save folder and deleted the files there, but I still get a segfault before it even loads the splash screen. I’m trying compiling with different optimization levels (i.e. not using -O3), but nothing has worked yet.