Help I made hole in my shelter

Hello there,

I’m new here and new to CDDA.

I’ve played a few sessions now and currently I got my longest run.
Started in a LMOE Shelter with a lot of perks, mad it myself easy because I needed some success to keep my interest in the game up.


Anyway, I now have quite a stack off food and water, books and other resources. because I didn’t wanted things to rot I read up how to get a fridge.

So, I discovered vehicle power.
Since I didn’t wanted the fumes to fill up my underground shelter, I decided to “add” a new room for that construction.
I got myself a pickaxe, teared down a wall and a few blocks of stone/dirt behind it.

Now I got no roof on some of these tiles :joy:
Tried to build a metall roof there, while being down in the shelter, resulted in a floor.
Trying to build them from upstairs the game says I can’t build at that location

Could someone tell how to build roofs in this game, that would be nice :smiley:

You essentially don’t build just a roof, but build a roof over a floor (although some of them can be dirt floor). Thus, you build from the room below.

From your description, I would have expected you to get a metal floor AND a metal roof above that.

The game is quirky in that you can’t build in a “normal” way of building walls, then a floor, and then a roof over it. I believe it’s because of how tiles are handled from a 3 dimension perspective.

Haven’t built in a while but… weren’t also there some requirements about having walls strong enough to support the roof? :thinking:

Well, you have to have supporting walls or roof on at least two sides to build a roof/floor combo, and I think there are some kinds of walls that don’t support roofs.
I have a vague recollection of a discussion about a maximum distance before requiring support underneath, but I think it was about introducing it, not something that already existed (if you require pillars in an underground garage, they’d have to be spaced sufficiently far apart that the game’s vehicles can actually move around them with the weird center swivel turn logic used).

It’s a bit hard to guess what’s going on without knowing the version you’re playing (especially since the stable and experimental are really far apart).

However, assuming you’re playing build 2021-06-13-0522 or newer (and also assuming that this didn’t change again), you were doing it right the first time: Building a roof does build a floor downstairs with a “roof” part above it (resulting in a flat roof tile upstairs).

There are different reasons why it might not have worked out as you’ve expected.
The most obvious one would be that you did construct the roof on the wrong tile. It’s very likely that not the part of the upper floor collapsed that was right above the wall, but one (or multiple) to the side.
Please also note that counting the tiles from the stairs will likely lead to a wrong result, as the stairs might not be aligned.
If you have the Experimental 3D field of vision turned on in the options, you can use the x to look around and the </> keys to move up/down and see which tile’s really above/below. If not (and if you want to keep it turned off), you could also just go to the hole in the floor (on the upper level) and drop a stone or another random item onto the tile with the hole in it and then go downstairs to check where it ended up to pinpoint the exact location.

Another possible reason would be - if you’re playing the 0.E stable - that the game needs a way to update the freshly generated roof. The easiest way to do that would be to save and exit the game and then load the world back up.

If there’s already roof tiles around it, this isn’t necessary. You can build a roof next to two roof tiles (or supporting wall tiles), as PALU pointed out.

build roofs just as you would walls with “*”
keep in mind that since you’re building load bearing items, they recquire more than a bit of fabrication knowledge, as well as heavy materials like lumber

I mean, that’s exactly what mgoerlich did, see:

The problem was/is - to my understanding -, that the hole in the upper floor is still not gone.

Its an old habit from tech support to state the obvious and avoid assumptions, since he didn’t state what actions he meant by “building”.
After all, never underestimate how many people haven’t tried “turning it off and and on again”…