Hard Crash (2062)

Hi, I am repeatedly getting a hard crash whenever I try to enter the World Generation screen. Initially, I did manage to get to the part where I enter the name for my new world, but then it crashed while trying to move onto the Character Creation section…

Edit - I have just seen Taika’s post below, so thought I would add more information. As per usual, I have gone through all the Options and have altered quite a few settings, in each area. The one of note, with regard to what Taika said, is that I play with fullscreen enabled, using 160x45 terminal width and height…

Version commit string? OS? Tiles or Terminal?

We need more information before we can help you.


I am using Windows 7 64, tiles.

Not sure what you mean by Version Commit String, but I will give you the number that is listed in the main menu area, which is: 5ea9a28

As a test, I tried disabling fullscreen, but the crash still occurs.

Windows displays the error message: cataclysm-tiles.exe has stopped working

Edit - Further to this, I tried changing the tileset that I am using, from RetroDays20px to MShock32, but still the crash occurs. If there is any further information you need, just let me know…

The version string is that 1a11a1 whatever number on the start screen. (I think :wink:

Yeah, that’s the number I’ve given in my reply. (or maybe not)

Either way, it seems there are quite a few of us getting these crashes with the 2062 build…

Yeah, a potential fix for it is already up for review now. :slight_smile:

Awesome! :smiley:

Fix merged, though since I didn’t have the crash when testing the original issue I’m not sure that I could verify that it’s fixed. Fire up 2063 and let us know!