Coming back, unable to set up

Hello CDDA comunity,

I haven’t played for a very long time (I even used to LP it years ago), it’s been one of my favorite game and I’ve spent hundreds of hours enjoying it. I’m trying to set the game up and play it again right now.

However, after 5 hours of working on it, I haven’t managed to get it working the way I want and I’ve stopped trying on my own.

I’ve downloaded the launcher which looks great, most of it works fine. But, on the stable build, I can barely activate any mods, while on the experimental they can be enabled but crash when loading the world. That’s a first problem, though I’m willing to play with that setup.

The next problem is more crippling : I cannot seem to deactivate the filthy clothes mechanic by any means.
In experimental, I’m launching games without the “filthy clothes” mod but I’m still getting filthy clothes (and their maluses) ingame. I’ve tried erasing the mod file entirely from my computer but the feature is still on.
When I’m on the stable build, a “no filthy clothing” mod appears in the installed list, but I cannot enable it ingame.
I’ve also tried the non-launcher version of the game (both experimental&stable) and haven’t managed to get rid of the mechanic.

I’ve spent way too long on this, is there a solution or should I just stop bothering and play something else ?
I was really excited to get back to one of my all-time favourite…

I don’t think you can get rid of it anymore. Just like simplified nutrition seems to be gone. Honestly a majority of mods just crash and error everything so mostly playing very vanilla these days aside from aftershock.

What mod(s), what’s the crash message?

Filthy clothes are in the main game, not (or no longer) a mod.

For stable 0.E: Open the data/mods/No_Filthy_Clothes folder and open the modinfo.json in any text editor. Remove the whole "obsolete": true line from that file, including the comma one line above. Now you should be able to activate the mod in game.

Also, since you’ve written that you removed the “filthy clothes” mod from the folder, I think you might installed the new version over an older version, which would explain why some of the mods no longer work. You might want to make a new, clean install so you don’t try to activate older (not compatible) mods.
After that, you might want to take a look at TheGoatgod’s mod compilation and see if some of the “older” mods are available there (and should not crash, as s-/he does her/his best to keep them up to date or at least working).

Which is funny, as that one’s actually the one mod that crashed the game recently…

1 Like

Thank you for all the bits of info.

If I remember correctly (since I’ve hidden the crash messages and changed versions) :

  • Medieval and Historic…
  • Icecoon’s Arsenal
  • Cataclysm++
  • More Buildings
  • More Survival Tools
  • Vehicle Additions Pack
    No full crashes, though the window would stop responding and the game would go back to the main menu (when loading mods from creating new character).
    From memory, messages were mostly about weapons, though there was one about grey text and one about martial art missing “initiate”.

That explains a lot haha, I’ll try to mod it out somehow (getting rid of the [FILTHY] tag on monster works ?).
Otherwise I’ll just cheat in the items to clean stuff when needed.

I’ll try the modpack, thank you for the link. A clean install is again in order I suppose.

Unless any mod have broken recently, every mod will load from my compilation. I still have to work on the less worrying bugs. There’s alot. Only place I haven’t dived into is rebalanced mods remember to post bugs on my repo or on the forums links can be found on my thread

The game works great on the stable build with your pack, even with tons of mods.

Thank you for your hard work, it’s really apreciated !

1 Like

Yes, that should work, but it’s a lot of effort (unless you use a find & replace over all the monster files).
If you haven’t done that already, it’d probably easier to edit and reenable the No_Filthy_Clothes mod for the stable 0.E release, or to use the one that comes with the linked mod compilation (found in data/Rebalance_mods/mods/No_Filthy_Clothes) - unless it’s somehow broken.

You can just download my compilation and over ride the mods folder I done this for qol and nobody tells people despite knowing I’ve done this