So uhh... That's odd

well okay

There’s an easy fix for that:


Since you posted this in The Garage, I have to assume that there’s something wrong with it.
However, you did not post any details. You know, like…

  • What’s wrong with it.
  • Operating System.
  • Game version.
  • Do you use the launcher.
  • Mods.
  • What you did when “it” happend.
    The topic title does not help either.

I guess your problem is that “pixelated” screen. But I don’t know for sure, maybe that’s your tile set. Maybe you use ReShade. Maybe you compressed the image and it created those artifacts and you actually want to point out something in the chatlog.
Maybe it is not a problem and you posted your new mod/idea/you-name-it in the wrong forum section - happens from time to time.
I don’t know.

We can play a guessing game for a few posts unless someone had exactly this error previously and knows what’s going on… or we can try to fix your problem, if there is one - your choise.

So let’s get started:
I saw this once myself in an other game, so it’s possible that the problem (if it is one) is hardware related:

  • Maybe your graphic card is defective - let’s hope it’s not.
  • Maybe your graphic card driver is not up to date - update it.
  • Maybe (one of) your RAM has a defect.
  • Maybe your mainboard has a defect.

That aside… let’s assume it’s a bug in the game. More information would help:

  • Did it spontaneously turn like that (from one step to an other)?
  • Did a restart fix it?
  • Did this happen after an update?
  • Did you change some of the colors or overlay colors?
  • Did the game crash?
  • Are there any important messages in the debug log?
  • Did you switch to an other renderer (found in Options->Graphics)?
  • Since the area around you is green… do you wear night vision goggles (or have the related CBM turned on)?
  • Does your character wear socks in sandals?
  • Were you able to fix “it”?

Now hold up a second. You can’t just ask somebody if they wear socks with sandals. Wars have started over that sort of conjecture.


Well, technically I’ve asked him about his character :innocent:

Oh, I didn’t know… That was the plan! Muahaha :boom: !

1 Like

Okay, that’s a lot of questions.
I thought that because that could be a specific field in which I could give info, it would narrow down the possibilities, but nah. Lets answer them, shall we?
Yeah right, the wrongie is that colored static in every black tile.
Win 10
10825, restored from 10830 or 831, i think?
Yes, I do use the launcher and mods, which are for this world:
Blaze Industries, XEAS, Graphical overmap, Vampiric Stuff, Fuji’s Mil. Profession pack, Mut. Chances, SpeedyDex, Stats through Kills and Skills.
It appeared when I stepped in some direction, moving blindzones.

Could it be hardware? That’s pretty possible.
I have a laptop that has some minor issues with drivers, most disturbing is a really old bug, that if it didnt play any sounds in a while, a source of sound won’t start playing immediatly, but after a few seconds delay. (e.g. i start playing video. First two seconds there’s silence, on second 3 it starts playing sound of second 3, so its syncd, but If i want to listen to first two seconds, I have to play video over). The reason i’m giving such a detailed explanation is that its roughly the same time as the jitter in the game before the visual bug. Takes same time of idleness to appear, takes same time of stuttering.
Could be also a hardware defect issue, as it due to a really unlucky mishap, my laptop has a rather big crack on its surface at the charging part.
Both of those are really questionable, though, for one reason: no other issues in other apps. Doesnt looks like a GPU mailfunction, cuz I wouldnt be able to screen it then, I think?
Thaaaaaat aside…
The nature of bug is spotaneous. The only condition so far is that there should be a delay big enough before previous action, which is like 30 seconds or a minute. It happens like that: pressing direction doesn’t meet with immediate response. Instead, it jitters for a sec and then all the “blind” tiles lit up like Christmas tree.
Yes, complete restart of the game fixes it. Quitting the world and launching it again doesn’t.
Check above. Appeared only after restoration to previous build.
Nope, i didn’t change any overlay colors. Added Graphical overmap though.
Game didn’t crash even once.
Totally oblivious to debug stuff, but seems like no messages related to that.
Open GL seems to have same problem as Direc3d11.
Yes, as it’s a milbase scenario, I wear Night vision goggles.
No, my char is a decent Mil. Recruit. He wears army boots.
Nope, the bug persists, allthough it seems to appear slightly less often in OpenGL.

Toggle the key for map memory cant remember what it is right now but press it and see I know its shift+ some thing.

see what happens

Sadly, does not work. Sometimes it does that in the inventory as well.

OK whats ya tempts.
When this happens it some times indicates a fault could be over heating or faulty ram on GPU ETC

Thank you for your answers.

Usually more info is always better, since it’s always possible to skip uninteresting stuff while reading it, but even things that seem unimportant at first can lead to a fix.

That’s an interesting detail. And could also be an indicator that this bug can’t get fixed in cataclysm…

I guess that that alone is not responsible for such a visual bug, especially if it is not constant. But I also think that whatever caused a crack on the surface quite possible has damaged internal components too…

That problem I had with my RAM only showed in the game “Spore”. That is… until the PC crashed much later on and I was unable to have it run for longer times (it froze or crashed at random points).
Different programs might behave differently on hardware bugs. Some crash, some show graphic (or sound) glitches, some replace every byte of your savegame with a “0” and some have no (visible) problems…

The GPU processes your data and stores it on the graphic cards (or onboard chips) cache until it is displayed. Screenshot functions (and recording software) mostly copy their stuff from that cache. That usually means; if the CPU, GPU or any memory is damaged, it can show up on a screenshot. Screen damage (or cable damage) will not.

I’m not familiar enough with that matter to say for sure, but that sounds like it’s something related to the processing of the image on itself (driver/hardware). Since it seems to affects mostly dark colored tiles, maybe there’s some kind of overflow?
But there’s also quite the chance that there’s something going wrong on cataclysm’s side (renderer).

Hm, interesting, but sadly nothing obvious. Maybe something went wrong during the installation?

Does the bug persist even if you deactivate night vision?

How disappointing!

This is very interesting. I believe to see part of the loading screen in your inventory (the red in the middle). So it seems to have that still in cache.
Also something to note: The black/empty space on your inventory and sidebar are not affected, even though it has the same color value as the empty space on your main playscreen. This could indicate that the renderer somehow gives up.
Those text sections that can still be read on your inventory screenshot… Did you move the cursor over it and it made it readable again or was it like that from the start?

Now, I think there are a few things you could try.
But first I’d like to know what some of your settings are… Under Options->Graphics, what values do these settings have (a screenshot works too)?:

  • Force redraw
  • Font blending
  • SDL ASCII lines
  • Fullscreen
  • Use color modulated textures

Other than that, try different renderers. You wrote that you tried Direct3d11 and OpenGL, but nothing about the others (Direct3D, Software (with and without framebuffer acceleration)).

More time intensive but maybe helpful: Since it happend after downgrading the game… Reinstall the game completely. Make a backup, delete (or just move) the folder of the game, redownload it with the launcher and run a test world while trying to get the bug the best you can.
If it runs fine, copy the content of your config folder over to the newly installed one (overwriting the existing files) and try again.
If it still runs fine, copy over your save from the backup and play normally, hoping to never run into this problem again.
If the bug still persists after redownloading the game, we have to take a different approach. If it happens after moving over the config files, it might be something in the config (that could be solved quickly by deleting the config files and change the settings back to your liking in the game after the game recreated the files). If it happens after moving over your save, it might be related to that.