Crash When Examining Vehicle

I am using version 10725. This is my first time playing with nested containers. I attempted to examine a vehicle and the game hard crashed and said it was a segmentation fault. I don’t know what additional information I can give I hope this helps

  • Your Operating System
  • Which vehicle?
  • Can you reproduce the crash reliably?
  • Do you use mods? What mods?
  • I’m sure it says something about a log. That could/would be helpful.

I tried to post but it refused me saying I cannot post more than two usernames. Before figuring out which usernames I used, I am posting my reply as an image.
Hope it helps

I guess you couldn’t post it because there are @'s in the crash log and it tried to translate them to a username.
You can try to put the log as a preformatted text the next time, this should prevent the error message. But pictures are fine too.

Thank you for the log.
Sadly, this crash log basically does not say anything (or at least nothing that I could make sense of).
I’m on a slightly newer build version (although I didn’t see any changes done to vehicles between the versions) and, using your given mod list, I was unable to reproduce this error (yet).
I’ll run a bit around and checking every vehicle and see if I’m able to crash my game.

May I ask where you’re examining the vehicles? Somewhere at it’s side, on a container like the trunk or specifically the driver seat?

I can attest to having this same issue. Mainly with certain atomic vehicles it Segfault crashes. I have tested in most locations, including examining from inside and been getting this crash. Not sure entirely how to do the posting of the crashlog, though it’s basically the same as what was posted by Xing.

For me I am usually examining side tiles, but in this case I think I have tried by now to examine half of the vehicle at one point or another, always with a crash.

After a lot of trying - and I mean a lot; almost 4 hours (which I probably should have invested into sleep) with no success, I was ready to give up.
But I’ve done it, the last car (Atomic SUV) I’ve went to check… It crashed the game.
Here’s my crash log:

The program has crashed.
See the log file for a stack trace.
CRASH LOG FILE: ./config/crash.log
VERSION: 0.E-2901-g975fc77
TYPE: Signal
MESSAGE: SIGSEGV: Segmentation fault

    (dbghelp: @0x657256[cataclysm-tiles.exe+0x257256]), 
    (libbacktrace: Z21debug_write_backtraceRSo+0x56@0x657256),
    (libbacktrace: 0x657256    [unknown src]:0    [unknown func]),
    (dbghelp: @0x6388ff[cataclysm-tiles.exe+0x2388ff]), 
    (libbacktrace: log_crash+0x4af@0x6388ff),
    (libbacktrace: 0x6388ff    [unknown src]:0    [unknown func]),
    (dbghelp: @0x6395d2[cataclysm-tiles.exe+0x2395d2]), 
    (libbacktrace: signal_handler+0x32@0x6395d2),
    (libbacktrace: 0x6395d2    [unknown src]:0    [unknown func]),
    (dbghelp: SMPEG_error+0x4b034@0x10d54e0[cataclysm-tiles.exe+0xcd54e0]), 
    (libbacktrace: gnu_exception_handler+0x70@0x10d54e0),
    (libbacktrace: 0x10d54e0    /home/narc/src/mxe/tmp-gcc-x86_64-w64-mingw32.static/gcc-5.4.0.build_/mingw-w64-v5.0.2/mingw-w64-crt/crt/crt_handler.c:223    _gnu_exception_handler),
    (dbghelp: _C_specific_handler+0x8c@0x77c67258[ntdll.dll+0x57258]), 
    (backtrace_syminfo failed: errno = -1, msg = no symbol table in PE/COFF executable),
    (backtrace_pcinfo failed: errno = -1, msg = no debug info in PE/COFF executable),
    (dbghelp: _chkstk+0x9d@0x77c7be9d[ntdll.dll+0x6be9d]), 
    (backtrace_syminfo failed: errno = -1, msg = no symbol table in PE/COFF executable),
    (backtrace_pcinfo failed: errno = -1, msg = no debug info in PE/COFF executable),
    (dbghelp: RtlInitializeResource+0x53a@0x77c5040a[ntdll.dll+0x4040a]), 
    (backtrace_syminfo failed: errno = -1, msg = no symbol table in PE/COFF executable),
    (backtrace_pcinfo failed: errno = -1, msg = no debug info in PE/COFF executable),
    (dbghelp: KiUserExceptionDispatcher+0x2e@0x77c7b53e[ntdll.dll+0x6b53e]), 
    (backtrace_syminfo failed: errno = -1, msg = no symbol table in PE/COFF executable),
    (backtrace_pcinfo failed: errno = -1, msg = no debug info in PE/COFF executable),
    (dbghelp: @0x8e07f1[cataclysm-tiles.exe+0x4e07f1]), 
    (libbacktrace: ZNK11item_pocket13ammo_capacityERK9string_idI15ammunition_typeE+0x21@0x8e07f1),
    (libbacktrace: 0x8e07f1    [unknown src]:0    [unknown func]),
    (dbghelp: @0x8a20a8[cataclysm-tiles.exe+0x4a20a8]), 
    (libbacktrace: ZNK13item_contents13ammo_capacityERK9string_idI15ammunition_typeE+0x48@0x8a20a8),
    (libbacktrace: 0x8a20a8    [unknown src]:0    [unknown func]),
    (dbghelp: @0xfd7817[cataclysm-tiles.exe+0xbd7817]), 
    (libbacktrace: ZNK12vehicle_part13ammo_capacityERK9string_idI15ammunition_typeE+0x37@0xfd7817),
    (libbacktrace: 0xfd7817    [unknown src]:0    [unknown func]),
    (dbghelp: @0xfd7e0a[cataclysm-tiles.exe+0xbd7e0a]), 
    (libbacktrace: ZNK12vehicle_part10can_reloadERK4item+0x22a@0xfd7e0a),
    (libbacktrace: 0xfd7e0a    [unknown src]:0    [unknown func]),
    (dbghelp: @0xf48e76[cataclysm-tiles.exe+0xb48e76]), 
    (libbacktrace: ZN12veh_interact7cant_doEc+0x4a6@0xf48e76),
    (libbacktrace: 0xf48e76    [unknown src]:0    [unknown func]),
    (dbghelp: @0xf4998f[cataclysm-tiles.exe+0xb4998f]), 
    (libbacktrace: ZN12veh_interact12display_modeEv+0x1af@0xf4998f),
    (libbacktrace: 0xf4998f    [unknown src]:0    [unknown func]),
    (dbghelp: @0xf678ed[cataclysm-tiles.exe+0xb678ed]), 
    (libbacktrace: ZNSt17_Function_handlerIFvRK10ui_adaptorEZN12veh_interact24create_or_get_ui_adaptorEvEUlS2_E0_E9_M_invokeERKSt9_Any_dataS2_+0x14d@0xf678ed),
    (libbacktrace: 0xf678ed    [unknown src]:0    [unknown func]),
    (dbghelp: @0xf3faaa[cataclysm-tiles.exe+0xb3faaa]), 
    (libbacktrace: ZN10ui_adaptor18redraw_invalidatedEv+0xda@0xf3faaa),
    (libbacktrace: 0xf3faaa    [unknown src]:0    [unknown func]),
    (dbghelp: @0xf5d9d0[cataclysm-tiles.exe+0xb5d9d0]), 
    (libbacktrace: ZN12veh_interact12do_main_loopEv+0x120@0xf5d9d0),
    (libbacktrace: 0xf5d9d0    [unknown src]:0    [unknown func]),
    (dbghelp: @0xf5e0d7[cataclysm-tiles.exe+0xb5e0d7]), 
    (libbacktrace: ZN12veh_interact3runER7vehicleRK5point+0x27@0xf5e0d7),
    (libbacktrace: 0xf5e0d7    [unknown src]:0    [unknown func]),
    (dbghelp: @0x73d522[cataclysm-tiles.exe+0x33d522]), 
    (libbacktrace: ZN4game12exam_vehicleER7vehicleRK5point+0x22@0x73d522),
    (libbacktrace: 0x73d522    [unknown src]:0    [unknown func]),
    (dbghelp: @0xff0d5f[cataclysm-tiles.exe+0xbf0d5f]), 
    (libbacktrace: ZN7vehicle13interact_withERK8tripointi+0x183f@0xff0d5f),
    (libbacktrace: 0xff0d5f    [unknown src]:0    [unknown func]),
    (dbghelp: @0x784212[cataclysm-tiles.exe+0x384212]), 
    (libbacktrace: ZN4game7examineERK8tripoint+0x2a2@0x784212),
    (libbacktrace: 0x784212    [unknown src]:0    [unknown func]),
    (dbghelp: @0x784b91[cataclysm-tiles.exe+0x384b91]), 
    (libbacktrace: ZN4game7examineEv+0x141@0x784b91),
    (libbacktrace: 0x784b91    [unknown src]:0    [unknown func]),
    (dbghelp: @0x7b72df[cataclysm-tiles.exe+0x3b72df]), 
    (libbacktrace: ZN4game13handle_actionEv+0x642f@0x7b72df),
    (libbacktrace: 0x7b72df    [unknown src]:0    [unknown func]),
    (dbghelp: @0x77b63f[cataclysm-tiles.exe+0x37b63f]), 
    (libbacktrace: ZN4game7do_turnEv+0xc5f@0x77b63f),
    (libbacktrace: 0x77b63f    [unknown src]:0    [unknown func]),
    (dbghelp: IMG_LoadWEBP_RW+0x6e1ec8@0x18a9218[cataclysm-tiles.exe+0x14a9218]), 
    (libbacktrace: main+0x11a8@0x18a9218),
    (libbacktrace: 0x18a9218    [unknown src]:0    [unknown func]),
    (dbghelp: @0x4013ed[cataclysm-tiles.exe+0x13ed]), 
    (libbacktrace: _tmainCRTStartup+0x23d@0x4013ed),
    (libbacktrace: 0x4013ed    /home/narc/src/mxe/tmp-gcc-x86_64-w64-mingw32.static/gcc-5.4.0.build_/mingw-w64-v5.0.2/mingw-w64-crt/crt/crtexe.c:336    __tmainCRTStartup),
    (dbghelp: @0x4014fb[cataclysm-tiles.exe+0x14fb]), 
    (libbacktrace: WinMainCRTStartup+0x1b@0x4014fb),
    (libbacktrace: 0x4014fb    /home/narc/src/mxe/tmp-gcc-x86_64-w64-mingw32.static/gcc-5.4.0.build_/mingw-w64-v5.0.2/mingw-w64-crt/crt/crtexe.c:186    WinMainCRTStartup),
    (dbghelp: BaseThreadInitThunk+0xd@0x77b0556d[kernel32.dll+0x1556d]), 
    (backtrace_syminfo failed: errno = -1, msg = no symbol table in PE/COFF executable),
    (backtrace_pcinfo failed: errno = -1, msg = no debug info in PE/COFF executable),
    (dbghelp: RtlUserThreadStart+0x1d@0x77c6372d[ntdll.dll+0x5372d]), 
    (backtrace_syminfo failed: errno = -1, msg = no symbol table in PE/COFF executable),
    (backtrace_pcinfo failed: errno = -1, msg = no debug info in PE/COFF executable),

Now, my log shows some more and important information: Apparently (if I get this right) it crashed when it tried to load/show the ammo capacity of some vehicle part; assumingly the one from the mini reactor (or the storage battery).

I’ll try to work it out when I’m back from sleep and work, if it isn’t fixed in a release by then.

Thank you for your informations, @Psychopathic_Magno & @Xing.

PS: Actually… Looks like they are working on it already:

Seeing that the (normal) Atomic Car does not crash (or at least did not with all the ones I’ve checked), it might has something to do with the JSON? We’ll see…
A found (normal) Atomic Car actually crashes if one tries to re[f]ill it…

…but it does not crash if one tries to refill a spawned in (and slightly depleted) Atomic Car. It also shows the correct charges. So, what’s the difference between the naturally spawned and the debug spawn? Besides the damage? Or is that it?

… The game also crashes after damaging the reactor until it starts draining, waiting until it’s drained and then examining it. It does not crash if examined while it is draining. So… does it have a problem to show 0 charges? Or does it drain further than that?

Wow, thanks for all that testing and finding information. I hope you did get some sleep though :slight_smile:
After reading your post I tried to do some testing on my own. I found out by chance that you create wreckage if you spawn a vehicle on top of another one and proceeded to spawn bicycles and minicars on my Atomic SUV. I noticed the crash happens still upon examining the wreckage when the minireactor is still somewhat intact (most of the time) whereas you can examine it freely when it is completely broken (greyed out). I said most of the time because twice I managed to examine the wreckage with the minireactor still sortof alive (and draining). The first time I didnt look, but the second time i checked for the middle window in examine mode and noticed the battery, motor and tank have charges or something written to the right of the middle window (like they should) whereas the minireactor had nothing there. I think the plutonium cells should be listed there? and if so, wouldnt that point strongly towards the plutonium cells being the culprit, like you suspected and like it is also written in the post you linked?

Anyway, thanks a lot already. I hope they will fix it soon :slight_smile:

Edit: Afterwards I had another idea and checked the savegame file and this is what it says for the minireactor part:

I have no idea if this is helpful, for me it certainly isn’t, but maybe for you (if information about or changing vehicle parts can also be done via the debug menu in game I don’t know how to, so I had to use the savegame file)

Edit2: And this is what my savegame says when I spawn an Atomic SUV:
The difference being the added plutonium cell and enabled being true instead of false

Edit3: starting my SUV and examining it after driving a few tiles changed nothing (I had to edit my stats a bit in order to be able to hotwire it). The item looked the same in the savegame file, and also the game crashed upon examining the SUV as usual. I tried editing the savegame to change enabled to true (but not adding plutonium cells) which still crashed the game upon examining the SUV, and adding the contents bracket gave me two of the red on black error messages (submap 0,0,0 was already loaded and file map file did not contain the expected submap number) and a not spawned Atomic SUV. Keep in mind that I don’t know what I am doing here, I guess there is another part of the savegame that needs to be changed in order to add the plutonium cells correctly to the minireactor. Now I’m out of ideas of what to try, but maybe it was helpful for something.

Edit4: correcting typos from typing in the dark

Thanks for your concern. Yeah, I did, but not enough…

Also thank you for your testing. From the information I had, I assumed that it’s crashing when the game tries to access either a non existant pocket (so it somehow removes the pocket when it’s empty) or it can’t handle that there are 0 plutonium cells left.

While I didn’t report back yesterday, I actually did some more testing. I hoped that changing the way it’s handled in the JSON could fix it, but it didn’t.

I’m really out of time, so I can’t investigate further, but it seems like Nannaquin found a fix for it over on GitHub anyway, so I guess we just have to wait for it to get merged.