[0.A-748-gde33abf] Can't Use Vehicle Mechanics

Since I tried 0.A this morning, after a short break from Cataclysm, I’ve been unable to use mechanics to edit vehicles in any way. I’ve been able to access the vehicle construction menu, and even begin vehicle construction, however when I press any of the vehicle construction options, such as ‘remove’, there is no response from the client. I have all the tools required to remove parts, and the necessary skill level. If I do not, it will prompt me in a reasonable manner, however if I meet all the prerequisites… nothing. Disappointing, because I wanted to slap solar panels onto my fridge, since it eats up power pretty fast. This also occurs with other vehicle options, such as ‘repair’, and ‘install’. Can’t do anything to vehicles.

I’ve tried this with all versions of 0.A Experimental that came out today (14/03), with the same result.

I can confirm this, can’t fill up gas tanks or water tanks either, can’t repair either. Basically whole vehicle screen ain’t working.

Fixed by PR #6636.

Thanks for reporting guys!